summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2016-07-01 16:06:41 -0700
committerJohn Crispin <john@phrozen.org>2016-07-01 15:25:31 +0200
commiteaaaf75a225fcdebb8914d5b4a046c88d2b3a105 (patch)
treedf501502c90c24ece5bdc8d8daa40220098835d2
parent0453f48e509077c83129b8aaceecb4e4430c8309 (diff)
downloadfstools-eaaaf75a225fcdebb8914d5b4a046c88d2b3a105.tar.gz
cmake: Find libubox/ulog.h
Add a CMake FIND_PATH and INCLUDE_DIRECTORIES searching for libubox/ulog.h. Some external toolchains which do not include standard locations would fail to find the header otherwise. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a6002e5..9a5a583 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,6 +38,9 @@ ADD_LIBRARY(ubi-utils STATIC
libubi/ubiutils-common.c)
INSTALL(TARGETS ubi-utils ARCHIVE DESTINATION lib)
+FIND_PATH(ubox_include_dir libubox/ulog.h)
+INCLUDE_DIRECTORIES(${ubox_include_dir})
+
SET_TARGET_PROPERTIES(ubi-utils PROPERTIES COMPILE_FLAGS
"-ffunction-sections -fdata-sections")