summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-05-09 12:37:42 +0200
committerDaniel Golle <daniel@makrotopia.org>2017-06-30 17:25:24 +0200
commitef2d4387ee99219f1ead6b4c4c19731d436de44b (patch)
tree0a2b9e4dd66bf005483918f35c51a098f4a47fcb
parent45c2a6ff74d4d26a29ed2e79f0d65b13a0caee20 (diff)
downloadfstools-ef2d4387ee99219f1ead6b4c4c19731d436de44b.tar.gz
fstools: use -Wno-format-truncation instead of -Wno-error=format-truncation
Fixes build error with older gcc Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 14b6e0a..56ffc01 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 2.6)
PROJECT(fs-tools C)
-ADD_DEFINITIONS(-Os -ggdb -Wall -Werror --std=gnu99 -Wmissing-declarations -Wno-error=format-truncation)
+ADD_DEFINITIONS(-Os -ggdb -Wall -Werror --std=gnu99 -Wmissing-declarations -Wno-format-truncation)
SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")