summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-03-05 19:44:31 +0100
committerSteven Barth <steven@midlink.org>2015-03-06 15:25:44 +0100
commit45fd905c980e56b20770d4b34556749fbca53fcc (patch)
tree7cc95ac2bb763181a7bd87567322f421fc49d7c0
parent212288ba1518c0fd4d44f22e7c2af09022944a9f (diff)
downloadnetifd-45fd905c980e56b20770d4b34556749fbca53fcc.tar.gz
netifd: fixes for json-c 0.12
Signed-off-by: John Crispin <blogic@openwrt.org>
-rw-r--r--CMakeLists.txt3
-rw-r--r--handler.h2
2 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e648b03..85527be 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,9 +18,8 @@ SET(SOURCES
macvlan.c ubus.c vlandev.c wireless.c)
-find_library(json NAMES json-c json)
SET(LIBS
- ubox ubus uci ${json} blobmsg_json)
+ ubox ubus uci json-c blobmsg_json)
IF (NOT DEFINED LIBNL_LIBS)
FIND_LIBRARY(libnl NAMES libnl-3 libnl nl-3 nl)
diff --git a/handler.h b/handler.h
index e96c05a..e3e2af5 100644
--- a/handler.h
+++ b/handler.h
@@ -15,7 +15,7 @@
#define __NETIFD_HANDLER_H
#include <libubox/blobmsg_json.h>
-#include <json/json.h>
+#include <json-c/json.h>
#include "config.h"
typedef void (*script_dump_cb)(const char *script, const char *name, json_object *obj);