summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorArne Kappen <arne.kappen@hhi.fraunhofer.de>2020-12-09 16:01:24 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-03-31 01:19:55 +0100
commit80bf9d74884693cf74914edafe2a0b5e5ed45ada (patch)
tree7a20c555ca6ff463a4e0ad75300b91dcfff597ac /CMakeLists.txt
parentb22f83d752d4d53e120bbbcb089ec2d980cbd957 (diff)
downloadnetifd-80bf9d74884693cf74914edafe2a0b5e5ed45ada.tar.gz
extdev: add support for external device handlers
This allows to integrate external daemons that configure network devices with netifd. At startup, netifd generates device handler stubs from descriptions in /lib/netifd/extdev-config via the mechanism in handler.c. These are then added to the list of device handlers. Device handlers stubs act as relays forwarding calls against the device handler interface to the external daemon. Signed-off-by: Arne Kappen <arne.kappen@hhi.fraunhofer.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9d19817..ca5d944 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,7 +20,8 @@ SET(SOURCES
interface.c interface-ip.c interface-event.c
iprule.c proto.c proto-static.c proto-shell.c
config.c device.c bridge.c veth.c vlan.c alias.c
- macvlan.c ubus.c vlandev.c wireless.c)
+ macvlan.c ubus.c vlandev.c wireless.c
+ extdev.c)
SET(LIBS