summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bcb5133..b3bf411 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,8 +24,16 @@ SET(SOURCES
extdev.c bonding.c)
-SET(LIBS
- ubox ubus uci json-c blobmsg_json)
+FIND_LIBRARY(uci NAMES uci)
+FIND_LIBRARY(ubox NAMES ubox)
+FIND_LIBRARY(ubus NAMES ubus)
+FIND_LIBRARY(json NAMES json-c json)
+FIND_LIBRARY(blobmsg_json NAMES blobmsg_json)
+
+SET(LIBS ${ubox} ${ubus} ${uci} ${json} ${blobmsg_json})
+
+FIND_PATH(ubox_include_dir libubox/usock.h)
+INCLUDE_DIRECTORIES(${ubox_include_dir})
IF (NOT DEFINED LIBNL_LIBS)
include(FindPkgConfig)