summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2021-02-27 19:12:10 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-02-27 23:13:55 +0000
commit1755000f4b70c366a178a88163655a156734392e (patch)
tree9b68e8c39ff3214775b9cac22787559f1e982849
parent620fff983871fef7c6020d9c58c476d316684cc6 (diff)
downloadopenwrt-1755000f4b70c366a178a88163655a156734392e.tar.gz
include: use cpio from staging dir
As we built our own CPIO now, use this version instead of whatever the host may or may not provide. Signed-off-by: David Bauer <mail@david-bauer.net>
-rw-r--r--include/image.mk2
-rw-r--r--include/kernel-defaults.mk2
-rw-r--r--include/unpack.mk2
3 files changed, 3 insertions, 3 deletions
diff --git a/include/image.mk b/include/image.mk
index 48911e4057..7f0d27b746 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -301,7 +301,7 @@ endif
ifdef CONFIG_TARGET_ROOTFS_CPIOGZ
define Image/Build/cpiogz
- ( cd $(TARGET_DIR); find . | cpio -o -H newc -R root:root | gzip -9n >$(BIN_DIR)/$(IMG_ROOTFS).cpio.gz )
+ ( cd $(TARGET_DIR); find . | $(STAGING_DIR_HOST)/bin/cpio -o -H newc -R root:root | gzip -9n >$(BIN_DIR)/$(IMG_ROOTFS).cpio.gz )
endef
endif
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 4b39296f8c..c246857cd3 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -163,7 +163,7 @@ ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS_SEPERATE),y)
ifeq ($(CONFIG_EXTERNAL_CPIO),y)
$(CP) $(CONFIG_EXTERNAL_CPIO) $(KERNEL_BUILD_DIR)/initrd.cpio
else
- ( cd $(TARGET_DIR); find . | cpio -o -H newc -R root:root > $(KERNEL_BUILD_DIR)/initrd.cpio )
+ ( cd $(TARGET_DIR); find . | $(STAGING_DIR_HOST)/bin/cpio -o -H newc -R root:root > $(KERNEL_BUILD_DIR)/initrd.cpio )
endif
$(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_BZIP2),bzip2 -9 -c < $(KERNEL_BUILD_DIR)/initrd.cpio > $(KERNEL_BUILD_DIR)/initrd.cpio.bzip2)
$(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_GZIP),gzip -f -S .gzip -9n $(KERNEL_BUILD_DIR)/initrd.cpio)
diff --git a/include/unpack.mk b/include/unpack.mk
index 6a56b8e742..ebece69978 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -40,7 +40,7 @@ ifeq ($(strip $(UNPACK_CMD)),)
UNPACK_CMD=$(DECOMPRESS_CMD) $(TAR_CMD)
endif
ifeq ($(EXT),cpio)
- UNPACK_CMD=$(DECOMPRESS_CMD) (cd $(1)/..; cpio -i -d)
+ UNPACK_CMD=$(DECOMPRESS_CMD) (cd $(1)/..; $(STAGING_DIR_HOST)/bin/cpio -i -d)
endif
ifeq ($(EXT),zip)
UNPACK_CMD=$(UNZIP_CMD)