summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 14 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b1fdd5b..e21a046 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,16 +19,27 @@ IF(APPLE)
LINK_DIRECTORIES(/opt/local/lib)
ENDIF()
+IF(BUILD_STATIC)
+ FIND_LIBRARY(ubox_library NAMES ubox.a)
+ FIND_LIBRARY(blob_library NAMES blobmsg_json.a)
+ELSE(BUILD_STATIC)
+ FIND_LIBRARY(ubox_library NAMES ubox)
+ FIND_LIBRARY(blob_library NAMES blobmsg_json)
+ENDIF(BUILD_STATIC)
+
+FIND_PATH(ubox_include_dir libubox/usock.h)
+INCLUDE_DIRECTORIES(${ubox_include_dir})
+
ADD_LIBRARY(ubus SHARED libubus.c libubus-io.c libubus-obj.c libubus-sub.c libubus-req.c libubus-acl.c)
-TARGET_LINK_LIBRARIES(ubus ubox)
+TARGET_LINK_LIBRARIES(ubus ${ubox_library})
ADD_EXECUTABLE(ubusd ubusd.c ubusd_id.c ubusd_obj.c ubusd_proto.c ubusd_event.c ubusd_acl.c ubusd_monitor.c)
-TARGET_LINK_LIBRARIES(ubusd ubox blobmsg_json ${json})
+TARGET_LINK_LIBRARIES(ubusd ${ubox_library} ${blob_library} ${json})
find_library(json NAMES json-c json)
ADD_EXECUTABLE(cli cli.c)
SET_TARGET_PROPERTIES(cli PROPERTIES OUTPUT_NAME ubus)
-TARGET_LINK_LIBRARIES(cli ubus ubox blobmsg_json ${json})
+TARGET_LINK_LIBRARIES(cli ubus ${ubox_library} ${blob_library} ${json})
ADD_SUBDIRECTORY(lua)
ADD_SUBDIRECTORY(examples)