summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Muecke <jens@nons.de>2008-08-24 19:28:09 +0200
committerFelix Fietkau <nbd@openwrt.org>2008-08-31 12:49:07 +0200
commit213d8d8934f797849eb80b7ac06b6d37f3090e40 (patch)
tree94a09690b28e883b84cae149bcfc6aad490a7999
parentf8cf80970bb8bd6e4c932b2cb14e57580e090488 (diff)
downloaduci-213d8d8934f797849eb80b7ac06b6d37f3090e40.tar.gz
Add mkdir to Makefile and Makefile.inc, use $prefix for binary
-rw-r--r--Makefile4
-rw-r--r--Makefile.inc1
2 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 1016fac..3e1d7ac 100644
--- a/Makefile
+++ b/Makefile
@@ -56,10 +56,12 @@ clean:
rm -f uci uci-static *.[oa] *.so* *.dylib* uci_config.h
install: all
+ $(MKDIR) -p $(DESTDIR)$(prefix)/lib
$(INSTALL) -m0644 libuci.a $(DESTDIR)$(prefix)/lib/
$(INSTALL) -m0755 $(SHLIB_FILE) $(DESTDIR)$(prefix)/lib/
ln -sf $(SHLIB_FILE) $(DESTDIR)$(prefix)/lib/libuci.$(SHLIB_EXT)
- $(INSTALL) -m0755 uci $(DESTDIR)/usr/bin/
+ $(MKDIR) -p $(DESTDIR)$(prefix)/bin
+ $(INSTALL) -m0755 uci $(DESTDIR)$(prefix)/bin/
test: all
make -C test
diff --git a/Makefile.inc b/Makefile.inc
index 2578c72..44c6aa5 100644
--- a/Makefile.inc
+++ b/Makefile.inc
@@ -11,6 +11,7 @@ LD=ld
CC=gcc
RANLIB=ranlib
INSTALL=install
+MKDIR=mkdir
ifeq ($(DEBUG),1)
COPTS = -O0