summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-11-14 22:38:57 +0100
committerFelix Fietkau <nbd@openwrt.org>2008-11-14 22:38:57 +0100
commitd788264ddc370ffb5f9fe1f451ac6845da0dfda0 (patch)
treeef86b5e2768e906ebf0f3b0399f2fbdc979ec866
parentbc7d0c4049b516945d4adae203575f8eddd94ce4 (diff)
downloaduci-d788264ddc370ffb5f9fe1f451ac6845da0dfda0.tar.gz
add libucimap
-rw-r--r--.gitignore1
-rw-r--r--Makefile12
-rw-r--r--uci_list.h601
-rw-r--r--ucimap-example.c117
-rw-r--r--ucimap.c290
-rw-r--r--ucimap.h116
6 files changed, 1134 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
index c84f7d6..f589c0c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
uci
uci-static
+ucimap-example
*.[oa]
*.so*
*.dylib*
diff --git a/Makefile b/Makefile
index 69a7431..ffa7be4 100644
--- a/Makefile
+++ b/Makefile
@@ -16,9 +16,10 @@ endef
LIBUCI_DEPS=file.c history.c list.c util.c uci.h uci_config.h uci_internal.h
-all: uci-static uci libuci.$(SHLIB_EXT)
+all: uci-static uci libuci.$(SHLIB_EXT) libucimap.a
cli.o: cli.c uci.h uci_config.h
+ucimap.o: ucimap.c uci.h uci_config.h ucimap.h uci_list.h
uci_config.h: FORCE
@rm -f "$@.tmp"
@@ -48,6 +49,11 @@ libuci.a: libuci-static.o
$(AR) rc $@ $^
$(RANLIB) $@
+libucimap.a: ucimap.o
+ rm -f $@
+ $(AR) rc $@ $^
+ $(RANLIB) $@
+
libuci.$(SHLIB_EXT): libuci-shared.o
$(LINK) $(SHLIB_FLAGS) -o $(SHLIB_FILE) $^ $(LIBS)
ln -sf $(SHLIB_FILE) $@
@@ -60,8 +66,8 @@ install: install-bin install-dev
install-dev: all
$(MKDIR) -p $(DESTDIR)$(prefix)/lib
$(MKDIR) -p $(DESTDIR)$(prefix)/include
- $(INSTALL) -m0644 libuci.a $(DESTDIR)$(prefix)/lib/
- $(INSTALL) -m0644 uci_config.h uci.h $(DESTDIR)$(prefix)/include/
+ $(INSTALL) -m0644 libuci.a libucimap.a $(DESTDIR)$(prefix)/lib/
+ $(INSTALL) -m0644 uci_config.h uci.h uci_list.h ucimap.h $(DESTDIR)$(prefix)/include/
install-bin: all
$(INSTALL) -m0755 $(SHLIB_FILE) $(DESTDIR)$(prefix)/lib/
diff --git a/uci_list.h b/uci_list.h
new file mode 100644
index 0000000..2959a06
--- /dev/null
+++ b/uci_list.h
@@ -0,0 +1,601 @@
+#ifndef _LINUX_LIST_H
+#define _LINUX_LIST_H
+
+#include <stddef.h>
+/**
+ * container_of - cast a member of a structure out to the containing structure
+ * @ptr: the pointer to the member.
+ * @type: the type of the container struct this is embedded in.
+ * @member: the name of the member within the struct.
+ *
+ */
+#ifndef container_of
+#define container_of(ptr, type, member) ( \
+ (type *)( (char *)ptr - offsetof(type,member) ))
+#endif
+
+
+/*
+ * Simple doubly linked list implementation.
+ *
+ * Some of the internal functions ("__xxx") are useful when
+ * manipulating whole lists rather than single entries, as
+ * sometimes we already know the next/prev entries and we can
+ * generate better code by using them directly rather than
+ * using the generic single-entry routines.
+ */
+
+struct list_head {
+ struct list_head *next, *prev;
+};
+
+#define LIST_HEAD_INIT(name) { &(name), &(name) }
+
+#define LIST_HEAD(name) \
+ struct list_head name = LIST_HEAD_INIT(name)
+
+static inline void INIT_LIST_HEAD(struct list_head *list)
+{
+ list->next = list;
+ list->prev = list;
+}
+
+/*
+ * Insert a new entry between two known consecutive entries.
+ *
+ * This is only for internal list manipulation where we know
+ * the prev/next entries already!
+ */
+static inline void __list_add(struct list_head *new,
+ struct list_head *prev,
+ struct list_head *next)
+{
+ next->prev = new;
+ new->next = next;
+ new->prev = prev;
+ prev->next = new;
+}
+
+/**
+ * list_add - add a new entry
+ * @new: new entry to be added
+ * @head: list head to add it after
+ *
+ * Insert a new entry after the specified head.
+ * This is good for implementing stacks.
+ */
+static inline void list_add(struct list_head *new, struct list_head *head)
+{
+ __list_add(new, head, head->next);
+}
+
+
+/**
+ * list_add_tail - add a new entry
+ * @new: new entry to be added
+ * @head: list head to add it before
+ *
+ * Insert a new entry before the specified head.
+ * This is useful for implementing queues.
+ */
+static inline void list_add_tail(struct list_head *new, struct list_head *head)
+{
+ __list_add(new, head->prev, head);
+}
+
+
+/*
+ * Delete a list entry by making the prev/next entries
+ * point to each other.
+ *
+ * This is only for internal list manipulation where we know
+ * the prev/next entries already!
+ */
+static inline void __list_del(struct list_head * prev, struct list_head * next)
+{
+ next->prev = prev;
+ prev->next = next;
+}
+
+/**
+ * list_del - deletes entry from list.
+ * @entry: the element to delete from the list.
+ * Note: list_empty() on entry does not return true after this, the entry is
+ * in an undefined state.
+ */
+static inline void list_del(struct list_head *entry)
+{
+ __list_del(entry->prev, entry->next);
+ entry->next = NULL;
+ entry->prev = NULL;
+}
+
+/**
+ * list_replace - replace old entry by new one
+ * @old : the element to be replaced
+ * @new : the new element to insert
+ *
+ * If @old was empty, it will be overwritten.
+ */
+static inline void list_replace(struct list_head *old,
+ struct list_head *new)
+{
+ new->next = old->next;
+ new->next->prev = new;
+ new->prev = old->prev;
+ new->prev->next = new;
+}
+
+static inline void list_replace_init(struct list_head *old,
+ struct list_head *new)
+{
+ list_replace(old, new);
+ INIT_LIST_HEAD(old);
+}
+
+/**
+ * list_del_init - deletes entry from list and reinitialize it.
+ * @entry: the element to delete from the list.
+ */
+static inline void list_del_init(struct list_head *entry)
+{
+ __list_del(entry->prev, entry->next);
+ INIT_LIST_HEAD(entry);
+}
+
+/**
+ * list_move - delete from one list and add as another's head
+ * @list: the entry to move
+ * @head: the head that will precede our entry
+ */
+static inline void list_move(struct list_head *list, struct list_head *head)
+{
+ __list_del(list->prev, list->next);
+ list_add(list, head);
+}
+
+/**
+ * list_move_tail - delete from one list and add as another's tail
+ * @list: the entry to move
+ * @head: the head that will follow our entry
+ */
+static inline void list_move_tail(struct list_head *list,
+ struct list_head *head)
+{
+ __list_del(list->prev, list->next);
+ list_add_tail(list, head);
+}
+
+/**
+ * list_is_last - tests whether @list is the last entry in list @head
+ * @list: the entry to test
+ * @head: the head of the list
+ */
+static inline int list_is_last(const struct list_head *list,
+ const struct list_head *head)
+{
+ return list->next == head;
+}
+
+/**
+ * list_empty - tests whether a list is empty
+ * @head: the list to test.
+ */
+static inline int list_empty(const struct list_head *head)
+{
+ return head->next == head;
+}
+
+/**
+ * list_empty_careful - tests whether a list is empty and not being modified
+ * @head: the list to test
+ *
+ * Description:
+ * tests whether a list is empty _and_ checks that no other CPU might be
+ * in the process of modifying either member (next or prev)
+ *
+ * NOTE: using list_empty_careful() without synchronization
+ * can only be safe if the only activity that can happen
+ * to the list entry is list_del_init(). Eg. it cannot be used
+ * if another CPU could re-list_add() it.
+ */
+static inline int list_empty_careful(const struct list_head *head)
+{
+ struct list_head *next = head->next;
+ return (next == head) && (next == head->prev);
+}
+
+static inline void __list_splice(struct list_head *list,
+ struct list_head *head)
+{
+ struct list_head *first = list->next;
+ struct list_head *last = list->prev;
+ struct list_head *at = head->next;
+
+ first->prev = head;
+ head->next = first;
+
+ last->next = at;
+ at->prev = last;
+}
+
+/**
+ * list_splice - join two lists
+ * @list: the new list to add.
+ * @head: the place to add it in the first list.
+ */
+static inline void list_splice(struct list_head *list, struct list_head *head)
+{
+ if (!list_empty(list))
+ __list_splice(list, head);
+}
+
+/**
+ * list_splice_init - join two lists and reinitialise the emptied list.
+ * @list: the new list to add.
+ * @head: the place to add it in the first list.
+ *
+ * The list at @list is reinitialised
+ */
+static inline void list_splice_init(struct list_head *list,
+ struct list_head *head)
+{
+ if (!list_empty(list)) {
+ __list_splice(list, head);
+ INIT_LIST_HEAD(list);
+ }
+}
+
+/**
+ * list_entry - get the struct for this entry
+ * @ptr: the &struct list_head pointer.
+ * @type: the type of the struct this is embedded in.
+ * @member: the name of the list_struct within the struct.
+ */
+#define list_entry(ptr, type, member) \
+ container_of(ptr, type, member)
+
+/**
+ * list_first_entry - get the first element from a list
+ * @ptr: the list head to take the element from.
+ * @type: the type of the struct this is embedded in.
+ * @member: the name of the list_struct within the struct.
+ *
+ * Note, that list is expected to be not empty.
+ */
+#define list_first_entry(ptr, type, member) \
+ list_entry((ptr)->next, type, member)
+
+/**
+ * list_for_each - iterate over a list
+ * @pos: the &struct list_head to use as a loop cursor.
+ * @head: the head for your list.
+ */
+#define list_for_each(pos, head) \
+ for (pos = (head)->next; pos != (head); \
+ pos = pos->next)
+
+/**
+ * __list_for_each - iterate over a list
+ * @pos: the &struct list_head to use as a loop cursor.
+ * @head: the head for your list.
+ *
+ * This variant differs from list_for_each() in that it's the
+ * simplest possible list iteration code, no prefetching is done.
+ * Use this for code that knows the list to be very short (empty
+ * or 1 entry) most of the time.
+ */
+#define __list_for_each(pos, head) \
+ for (pos = (head)->next; pos != (head); pos = pos->next)
+
+/**
+ * list_for_each_prev - iterate over a list backwards
+ * @pos: the &struct list_head to use as a loop cursor.
+ * @head: the head for your list.
+ */
+#define list_for_each_prev(pos, head) \
+ for (pos = (head)->prev; pos != (head); \
+ pos = pos->prev)
+
+/**
+ * list_for_each_safe - iterate over a list safe against removal of list entry
+ * @pos: the &struct list_head to use as a loop cursor.
+ * @n: another &struct list_head to use as temporary storage
+ * @head: the head for your list.
+ */
+#define list_for_each_safe(pos, n, head) \
+ for (pos = (head)->next, n = pos->next; pos != (head); \
+ pos = n, n = pos->next)
+
+/**
+ * list_for_each_prev_safe - iterate over a list backwards safe against removal of list entry
+ * @pos: the &struct list_head to use as a loop cursor.
+ * @n: another &struct list_head to use as temporary storage
+ * @head: the head for your list.
+ */
+#define list_for_each_prev_safe(pos, n, head) \
+ for (pos = (head)->prev, n = pos->prev; \
+ pos != (head); \
+ pos = n, n = pos->prev)
+
+/**
+ * list_for_each_entry - iterate over list of given type
+ * @pos: the type * to use as a loop cursor.
+ * @head: the head for your list.
+ * @member: the name of the list_struct within the struct.
+ */
+#define list_for_each_entry(pos, head, member) \
+ for (pos = list_entry((head)->next, typeof(*pos), member); \
+ &pos->member != (head); \
+ pos = list_entry(pos->member.next, typeof(*pos), member))
+
+/**
+ * list_for_each_entry_reverse - iterate backwards over list of given type.
+ * @pos: the type * to use as a loop cursor.
+ * @head: the head for your list.
+ * @member: the name of the list_struct within the struct.
+ */
+#define list_for_each_entry_reverse(pos, head, member) \
+ for (pos = list_entry((head)->prev, typeof(*pos), member); \
+ &pos->member != (head); \
+ pos = list_entry(pos->member.prev, typeof(*pos), member))
+
+/**
+ * list_prepare_entry - prepare a pos entry for use in list_for_each_entry_continue()
+ * @pos: the type * to use as a start point
+ * @head: the head of the list
+ * @member: the name of the list_struct within the struct.
+ *
+ * Prepares a pos entry for use as a start point in list_for_each_entry_continue().
+ */
+#define list_prepare_entry(pos, head, member) \
+ ((pos) ? : list_entry(head, typeof(*pos), member))
+
+/**
+ * list_for_each_entry_continue - continue iteration over list of given type
+ * @pos: the type * to use as a loop cursor.
+ * @head: the head for your list.
+ * @member: the name of the list_struct within the struct.
+ *
+ * Continue to iterate over list of given type, continuing after
+ * the current position.
+ */
+#define list_for_each_entry_continue(pos, head, member) \
+ for (pos = list_entry(pos->member.next, typeof(*pos), member); \
+ &pos->member != (head); \
+ pos = list_entry(pos->member.next, typeof(*pos), member))
+
+/**
+ * list_for_each_entry_continue_reverse - iterate backwards from the given point
+ * @pos: the type * to use as a loop cursor.
+ * @head: the head for your list.
+ * @member: the name of the list_struct within the struct.
+ *
+ * Start to iterate over list of given type backwards, continuing after
+ * the current position.
+ */
+#define list_for_each_entry_continue_reverse(pos, head, member) \
+ for (pos = list_entry(pos->member.prev, typeof(*pos), member); \
+ &pos->member != (head); \
+ pos = list_entry(pos->member.prev, typeof(*pos), member))
+
+/**
+ * list_for_each_entry_from - iterate over list of given type from the current point
+ * @pos: the type * to use as a loop cursor.
+ * @head: the head for your list.
+ * @member: the name of the list_struct within the struct.
+ *
+ * Iterate over list of given type, continuing from current position.
+ */
+#define list_for_each_entry_from(pos, head, member) \
+ for (; &pos->member != (head); \
+ pos = list_entry(pos->member.next, typeof(*pos), member))
+
+/**
+ * list_for_each_entry_safe - iterate over list of given type safe against removal of list entry
+ * @pos: the type * to use as a loop cursor.
+ * @n: another type * to use as temporary storage
+ * @head: the head for your list.
+ * @member: the name of the list_struct within the struct.
+ */
+#define list_for_each_entry_safe(pos, n, head, member) \
+ for (pos = list_entry((head)->next, typeof(*pos), member), \
+ n = list_entry(pos->member.next, typeof(*pos), member); \
+ &pos->member != (head); \
+ pos = n, n = list_entry(n->member.next, typeof(*n), member))
+
+/**
+ * list_for_each_entry_safe_continue
+ * @pos: the type * to use as a loop cursor.
+ * @n: another type * to use as temporary storage
+ * @head: the head for your list.
+ * @member: the name of the list_struct within the struct.
+ *
+ * Iterate over list of given type, continuing after current point,
+ * safe against removal of list entry.
+ */
+#define list_for_each_entry_safe_continue(pos, n, head, member) \
+ for (pos = list_entry(pos->member.next, typeof(*pos), member), \
+ n = list_entry(pos->member.next, typeof(*pos), member); \
+ &pos->member != (head); \
+ pos = n, n = list_entry(n->member.next, typeof(*n), member))
+
+/**
+ * list_for_each_entry_safe_from
+ * @pos: the type * to use as a loop cursor.
+ * @n: another type * to use as temporary storage
+ * @head: the head for your list.
+ * @member: the name of the list_struct within the struct.
+ *
+ * Iterate over list of given type from current point, safe against
+ * removal of list entry.
+ */
+#define list_for_each_entry_safe_from(pos, n, head, member) \
+ for (n = list_entry(pos->member.next, typeof(*pos), member); \
+ &pos->member != (head); \
+ pos = n, n = list_entry(n->member.next, typeof(*n), member))
+
+/**
+ * list_for_each_entry_safe_reverse
+ * @pos: the type * to use as a loop cursor.
+ * @n: another type * to use as temporary storage
+ * @head: the head for your list.
+ * @member: the name of the list_struct within the struct.
+ *
+ * Iterate backwards over list of given type, safe against removal
+ * of list entry.
+ */
+#define list_for_each_entry_safe_reverse(pos, n, head, member) \
+ for (pos = list_entry((head)->prev, typeof(*pos), member), \
+ n = list_entry(pos->member.prev, typeof(*pos), member); \
+ &pos->member != (head); \
+ pos = n, n = list_entry(n->member.prev, typeof(*n), member))
+
+/*
+ * Double linked lists with a single pointer list head.
+ * Mostly useful for hash tables where the two pointer list head is
+ * too wasteful.
+ * You lose the ability to access the tail in O(1).
+ */
+
+struct hlist_head {
+ struct hlist_node *first;
+};
+
+struct hlist_node {
+ struct hlist_node *next, **pprev;
+};
+
+#define HLIST_HEAD_INIT { .first = NULL }
+#define HLIST_HEAD(name) struct hlist_head name = { .first = NULL }
+#define INIT_HLIST_HEAD(ptr) ((ptr)->first = NULL)
+static inline void INIT_HLIST_NODE(struct hlist_node *h)
+{
+ h->next = NULL;
+ h->pprev = NULL;
+}
+
+static inline int hlist_unhashed(const struct hlist_node *h)
+{
+ return !h->pprev;
+}
+
+static inline int hlist_empty(const struct hlist_head *h)
+{
+ return !h->first;
+}
+
+static inline void __hlist_del(struct hlist_node *n)
+{
+ struct hlist_node *next = n->next;
+ struct hlist_node **pprev = n->pprev;
+ *pprev = next;
+ if (next)
+ next->pprev = pprev;
+}
+
+static inline void hlist_del(struct hlist_node *n)
+{
+ __hlist_del(n);
+ n->next = NULL;
+ n->pprev = NULL;
+}
+
+static inline void hlist_del_init(struct hlist_node *n)
+{
+ if (!hlist_unhashed(n)) {
+ __hlist_del(n);
+ INIT_HLIST_NODE(n);
+ }
+}
+
+
+static inline void hlist_add_head(struct hlist_node *n, struct hlist_head *h)
+{
+ struct hlist_node *first = h->first;
+ n->next = first;
+ if (first)
+ first->pprev = &n->next;
+ h->first = n;
+ n->pprev = &h->first;
+}
+
+
+/* next must be != NULL */
+static inline void hlist_add_before(struct hlist_node *n,
+ struct hlist_node *next)
+{
+ n->pprev = next->pprev;
+ n->next = next;
+ next->pprev = &n->next;
+ *(n->pprev) = n;
+}
+
+static inline void hlist_add_after(struct hlist_node *n,
+ struct hlist_node *next)
+{
+ next->next = n->next;
+ n->next = next;
+ next->pprev = &n->next;
+
+ if(next->next)
+ next->next->pprev = &next->next;
+}
+
+#define hlist_entry(ptr, type, member) container_of(ptr,type,member)
+
+#define hlist_for_each(pos, head) \
+ for (pos = (head)->first; pos; pos = pos->next)
+
+#define hlist_for_each_safe(pos, n, head) \
+ for (pos = (head)->first; pos; pos = n)
+
+/**
+ * hlist_for_each_entry - iterate over list of given type
+ * @tpos: the type * to use as a loop cursor.
+ * @pos: the &struct hlist_node to use as a loop cursor.
+ * @head: the head for your list.
+ * @member: the name of the hlist_node within the struct.
+ */
+#define hlist_for_each_entry(tpos, pos, head, member) \
+ for (pos = (head)->first; pos && \
+ ({ tpos = hlist_entry(pos, typeof(*tpos), member); 1;}); \
+ pos = pos->next)
+
+/**
+ * hlist_for_each_entry_continue - iterate over a hlist continuing after current point
+ * @tpos: the type * to use as a loop cursor.
+ * @pos: the &struct hlist_node to use as a loop cursor.
+ * @member: the name of the hlist_node within the struct.
+ */
+#define hlist_for_each_entry_continue(tpos, pos, member) \
+ for (pos = (pos)->next; pos && \
+ ({ tpos = hlist_entry(pos, typeof(*tpos), member); 1;}); \
+ pos = pos->next)
+
+/**
+ * hlist_for_each_entry_from - iterate over a hlist continuing from current point
+ * @tpos: the type * to use as a loop cursor.
+ * @pos: the &struct hlist_node to use as a loop cursor.
+ * @member: the name of the hlist_node within the struct.
+ */
+#define hlist_for_each_entry_from(tpos, pos, member) \
+ for (; pos && \
+ ({ tpos = hlist_entry(pos, typeof(*tpos), member); 1;}); \
+ pos = pos->next)
+
+/**
+ * hlist_for_each_entry_safe - iterate over list of given type safe against removal of list entry
+ * @tpos: the type * to use as a loop cursor.
+ * @pos: the &struct hlist_node to use as a loop cursor.
+ * @n: another &struct hlist_node to use as temporary storage
+ * @head: the head for your list.
+ * @member: the name of the hlist_node within the struct.
+ */
+#define hlist_for_each_entry_safe(tpos, pos, n, head, member) \
+ for (pos = (head)->first; \
+ pos && ({ n = pos->next; 1; }) && \
+ ({ tpos = hlist_entry(pos, typeof(*tpos), member); 1;}); \
+ pos = n)
+
+#endif
diff --git a/ucimap-example.c b/ucimap-example.c
new file mode 100644
index 0000000..4309a76
--- /dev/null
+++ b/ucimap-example.c
@@ -0,0 +1,117 @@
+/*
+ * ucimap-example - sample code for the ucimap library
+ * Copyright (C) 2008 Felix Fietkau <nbd@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License version 2
+ * as published by the Free Software Foundation
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ */
+#include <strings.h>
+#include <string.h>
+#include <stdlib.h>
+#include <unistd.h>
+#include <ucimap.h>
+
+struct uci_network {
+ struct list_head list;
+
+ const char *name;
+ const char *proto;
+ const char *ifname;
+ const char *ipaddr;
+ int test;
+ bool enabled;
+};
+
+static int
+network_init_section(struct uci_map *map, void *section, struct uci_section *s)
+{
+ struct uci_network *net = section;
+
+ INIT_LIST_HEAD(&net->list);
+ net->name = s->e.name;
+ net->test = -1;
+ return 0;
+}
+
+static int
+network_add_section(struct uci_map *map, void *section)
+{
+ struct uci_network *net = section;
+ struct uci_network **nptr = map->priv;
+
+ *nptr = net;
+ return 0;
+}
+
+struct uci_optmap network_smap_options[] = {
+ OPTMAP_OPTION(UCIMAP_STRING, struct uci_network, proto, .data.s.maxlen = 32),
+ OPTMAP_OPTION(UCIMAP_STRING, struct uci_network, ifname),
+ OPTMAP_OPTION(UCIMAP_STRING, struct uci_network, ipaddr),
+ OPTMAP_OPTION(UCIMAP_BOOL, struct uci_network, enabled),
+ OPTMAP_OPTION(UCIMAP_INT, struct uci_network, test),
+};
+
+struct uci_sectmap network_smap[] = {
+ {
+ .type = "interface",
+ .options = network_smap_options,
+ .alloc_len = sizeof(struct uci_network),
+ .init_section = network_init_section,
+ .add_section = network_add_section,
+ .n_options = ARRAY_SIZE(network_smap_options),
+ }
+};
+
+struct uci_map network_map = {
+ .sections = network_smap,
+ .n_sections = ARRAY_SIZE(network_smap),
+};
+
+
+int main(int argc, char **argv)
+{
+ struct uci_context *ctx;
+ struct uci_package *pkg;
+ struct uci_network *net = NULL;
+
+ ctx = uci_alloc_context();
+ ucimap_init(&network_map);
+
+ uci_load(ctx, "network", &pkg);
+
+ network_map.priv = &net;
+ ucimap_parse(&network_map, pkg);
+
+ if (!net)
+ goto done;
+
+ printf("New network section '%s'\n"
+ " type: %s\n"
+ " ifname: %s\n"
+ " ipaddr: %s\n"
+ " test: %d\n"
+ " enabled: %s\n",
+ net->name,
+ net->proto,
+ net->ifname,
+ net->ipaddr,
+ net->test,
+ (net->enabled ? "on" : "off"));
+
+ net->ipaddr = "2.3.4.5";
+ ucimap_set_changed(net, &net->ipaddr);
+ ucimap_store_section(&network_map, pkg, net);
+ uci_save(ctx, pkg);
+
+done:
+ ucimap_cleanup(&network_map);
+ uci_free_context(ctx);
+
+ return 0;
+}
diff --git a/ucimap.c b/ucimap.c
new file mode 100644
index 0000000..3c5fb31
--- /dev/null
+++ b/ucimap.c
@@ -0,0 +1,290 @@
+/*
+ * ucimap - library for mapping uci sections into data structures
+ * Copyright (C) 2008 Felix Fietkau <nbd@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License version 2
+ * as published by the Free Software Foundation
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ */
+#include <strings.h>
+#include <string.h>
+#include <stdlib.h>
+#include <unistd.h>
+#include "ucimap.h"
+
+
+int
+ucimap_init(struct uci_map *map)
+{
+ INIT_LIST_HEAD(&map->sdata);
+ return 0;
+}
+
+static void
+ucimap_free_section(struct uci_map *map, struct uci_sectmap_data *sd)
+{
+ void *section = sd;
+ int i;
+
+ section = (char *) section + sizeof(struct uci_sectmap_data);
+ if (!list_empty(&sd->list))
+ list_del(&sd->list);
+
+ if (sd->sm->free_section)
+ sd->sm->free_section(map, section);
+
+ for (i = 0; i < sd->allocmap_len; i++) {
+ free(sd->allocmap[i]);
+ }
+
+ free(sd->allocmap);
+ free(sd);
+}
+
+void
+ucimap_cleanup(struct uci_map *map)
+{
+ struct list_head *ptr, *tmp;
+
+ list_for_each_safe(ptr, tmp, &map->sdata) {
+ struct uci_sectmap_data *sd = list_entry(ptr, struct uci_sectmap_data, list);
+ ucimap_free_section(map, sd);
+ }
+}
+
+
+static int
+ucimap_parse_options(struct uci_map *map, struct uci_sectmap *sm, struct uci_sectmap_data *sd, struct uci_section *s)
+{
+ struct uci_element *e;
+ struct uci_option *o;
+ void *section = sd;
+ int i;
+
+ section = (unsigned char *) section + sizeof(struct uci_sectmap_data);
+ uci_foreach_element(&s->options, e) {
+ struct uci_optmap *om = NULL;
+
+ for (i = 0; i < sm->n_options; i++) {
+ if (strcmp(e->name, sm->options[i].name) == 0) {
+ om = &sm->options[i];
+ break;
+ }
+ }
+ if (!om)
+ goto next_element;
+
+ o = uci_to_option(e);
+ if(o->type != UCI_TYPE_STRING)
+ goto next_element;
+
+ switch(om->type) {
+ case UCIMAP_STRING: {
+ char **ptr;
+ if ((om->data.s.maxlen > 0) &&
+ (strlen(o->v.string) > om->data.s.maxlen))
+ goto next_element;
+
+ ptr = (char **) ((char *) section + om->offset);
+ *ptr = strdup(o->v.string);
+ sd->allocmap[sd->allocmap_len++] = *ptr;
+ } break;
+ case UCIMAP_BOOL: {
+ bool *ptr = (bool *)((char *)section + om->offset);
+ if (strcmp(o->v.string, "on"))
+ *ptr = true;
+ else if (strcmp(o->v.string, "1"))
+ *ptr = true;
+ else if (strcmp(o->v.string, "enabled"))
+ *ptr = true;
+ else
+ *ptr = false;
+ } break;
+ case UCIMAP_INT: {
+ int *ptr = (int *)((char *)section + om->offset);
+ char *eptr = NULL;
+ int val;
+
+ val = strtol(o->v.string, &eptr, om->data.i.base);
+ if (!eptr || *eptr == '\0')
+ *ptr = val;
+ } break;
+ }
+next_element:
+ continue;
+ }
+
+ return 0;
+}
+
+
+static int
+ucimap_parse_section(struct uci_map *map, struct uci_sectmap *sm, struct uci_section *s)
+{
+ struct uci_sectmap_data *sd = NULL;
+ void *section = NULL;
+ int err;
+
+ sd = malloc(sm->alloc_len + sizeof(struct uci_sectmap_data));
+ if (!sd)
+ return UCI_ERR_MEM;
+
+ memset(sd, 0, sm->alloc_len + sizeof(struct uci_sectmap_data));
+ INIT_LIST_HEAD(&sd->list);
+
+ sd->sm = sm;
+ sd->allocmap = malloc(sm->n_options * sizeof(void *));
+ if (!sd->allocmap)
+ goto error_mem;
+
+ sd->section_name = strdup(s->e.name);
+ if (!sd->section_name)
+ goto error_mem;
+
+ sd->cmap = malloc(BITFIELD_SIZE(sm->n_options));
+ if (!sd->cmap)
+ goto error_mem;
+
+ memset(sd->cmap, 0, BITFIELD_SIZE(sm->n_options));
+ sd->allocmap[sd->allocmap_len++] = (void *)sd->section_name;
+ sd->allocmap[sd->allocmap_len++] = (void *)sd->cmap;
+
+ section = (char *)sd + sizeof(struct uci_sectmap_data);
+
+ err = sm->init_section(map, section, s);
+ if (err)
+ goto error;
+
+ list_add(&sd->list, &map->sdata);
+ err = ucimap_parse_options(map, sm, sd, s);
+ if (err)
+ goto error;
+
+ err = sm->add_section(map, section);
+ if (err)
+ goto error;
+
+ return 0;
+
+error_mem:
+ if (sd->allocmap)
+ free(sd->allocmap);
+ free(sd);
+ return UCI_ERR_MEM;
+
+error:
+ ucimap_free_section(map, sd);
+ return err;
+}
+
+static int
+ucimap_fill_ptr(struct uci_ptr *ptr, struct uci_section *s, const char *option)
+{
+ struct uci_package *p = s->package;
+
+ memset(ptr, 0, sizeof(struct uci_ptr));
+
+ ptr->package = p->e.name;
+ ptr->p = p;
+
+ ptr->section = s->e.name;
+ ptr->s = s;
+
+ ptr->option = option;
+ return uci_lookup_ptr(p->ctx, ptr, NULL, false);
+}
+
+void
+ucimap_set_changed(void *section, void *field)
+{
+ char *sptr = (char *)section - sizeof(struct uci_sectmap_data);
+ struct uci_sectmap_data *sd = (struct uci_sectmap_data *) sptr;
+ struct uci_sectmap *sm = sd->sm;
+ int ofs = (char *)field - (char *)section;
+ int i;
+
+ for (i = 0; i < sm->n_options; i++) {
+ if (sm->options[i].offset == ofs) {
+ SET_BIT(sd->cmap, i);
+ break;
+ }
+ }
+}
+
+int
+ucimap_store_section(struct uci_map *map, struct uci_package *p, void *section)
+{
+ char *sptr = (char *)section - sizeof(struct uci_sectmap_data);
+ struct uci_sectmap_data *sd = (struct uci_sectmap_data *) sptr;
+ struct uci_sectmap *sm = sd->sm;
+ struct uci_section *s = NULL;
+ struct uci_element *e;
+ struct uci_ptr ptr;
+ int i, ret;
+
+ uci_foreach_element(&p->sections, e) {
+ if (!strcmp(e->name, sd->section_name)) {
+ s = uci_to_section(e);
+ break;
+ }
+ }
+ if (!s)
+ return UCI_ERR_NOTFOUND;
+
+ for (i = 0; i < sm->n_options; i++) {
+ struct uci_optmap *om = &sm->options[i];
+ static char buf[32];
+ const char *str = NULL;
+ void *p = (char *)section + om->offset;
+
+ if (!TEST_BIT(sd->cmap, i))
+ continue;
+
+ ucimap_fill_ptr(&ptr, s, om->name);
+ switch(om->type) {
+ case UCIMAP_STRING:
+ str = *((char **) p);
+ break;
+ case UCIMAP_INT:
+ sprintf(buf, "%d", *((int *) p));
+ str = buf;
+ break;
+ case UCIMAP_BOOL:
+ sprintf(buf, "%d", !!*((bool *)p));
+ str = buf;
+ break;
+ }
+ ptr.value = str;
+
+ ret = uci_set(s->package->ctx, &ptr);
+ if (ret)
+ return ret;
+
+ CLR_BIT(sd->cmap, i);
+ }
+
+ return 0;
+}
+
+
+void
+ucimap_parse(struct uci_map *map, struct uci_package *pkg)
+{
+ struct uci_element *e;
+ int i;
+
+ uci_foreach_element(&pkg->sections, e) {
+ struct uci_section *s = uci_to_section(e);
+
+ for (i = 0; i < map->n_sections; i++) {
+ if (strcmp(s->type, map->sections[i].type) != 0)
+ continue;
+ ucimap_parse_section(map, &map->sections[i], s);
+ }
+ }
+}
diff --git a/ucimap.h b/ucimap.h
new file mode 100644
index 0000000..0237fb1
--- /dev/null
+++ b/ucimap.h
@@ -0,0 +1,116 @@
+/*
+ * ucimap - library for mapping uci sections into data structures
+ * Copyright (C) 2008 Felix Fietkau <nbd@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License version 2
+ * as published by the Free Software Foundation
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ */
+#include <stdbool.h>
+#include "uci_list.h"
+#include "uci.h"
+
+#ifndef ARRAY_SIZE
+#define ARRAY_SIZE(x) (sizeof(x) / sizeof((x)[0]))
+#endif
+
+#define BITFIELD_SIZE(_fields) (((_fields) / 8) + 1)
+
+#define CLR_BIT(_name, _bit) do { \
+ _name[(_bit) / 8] &= ~(1 << ((_bit) % 8)); \
+} while (0)
+
+#define SET_BIT(_name, _bit) do { \
+ _name[(_bit) / 8] |= (1 << ((_bit) % 8)); \
+} while (0)
+
+#define TEST_BIT(_name, _bit) \
+ (_name[(_bit) / 8] & (1 << ((_bit) % 8)))
+
+#define OPTMAP_OPTION(_maptype, _type, _field, ...) \
+ { \
+ .type = _maptype, \
+ .name = #_field, \
+ .offset = offsetof(_type, _field), \
+ __VA_ARGS__ \
+ }
+
+struct uci_sectmap;
+struct uci_optmap;
+
+struct uci_map {
+ struct uci_sectmap *sections;
+ unsigned int n_sections;
+ struct list_head sdata;
+
+ void *priv; /* user data */
+};
+
+enum ucimap_type {
+ UCIMAP_STRING,
+ UCIMAP_BOOL,
+ UCIMAP_INT,
+};
+
+/* ucimap internal */
+struct uci_sectmap_data {
+ struct list_head list;
+ struct uci_sectmap *sm;
+ const char *section_name;
+ unsigned long allocmap_len;
+
+ /* list of allocations done by ucimap */
+ void **allocmap;
+
+ /* map for changed fields */
+ unsigned char *cmap;
+};
+
+struct uci_sectmap {
+ /* type string for the uci section */
+ const char *type;
+
+ /* length of the struct to map into */
+ unsigned int alloc_len;
+
+ /* give the caller time to initialize the preallocated struct */
+ int (*init_section)(struct uci_map *map, void *section, struct uci_section *s);
+
+ /* pass the fully processed struct to the callback after the section end */
+ int (*add_section)(struct uci_map *map, void *section);
+
+ /* let the callback clean up its own stuff in the section */
+ int (*free_section)(struct uci_map *map, void *section);
+
+ /* list of option mappings for this section */
+ struct uci_optmap *options;
+ unsigned int n_options;
+};
+
+struct uci_optmap {
+ unsigned int offset;
+ const char *name;
+ enum ucimap_type type;
+ union {
+ struct {
+ int base;
+ int min;
+ int max;
+ } i;
+ struct {
+ int maxlen;
+ } s;
+ } data;
+};
+
+extern int ucimap_init(struct uci_map *map);
+extern void ucimap_cleanup(struct uci_map *map);
+extern void ucimap_set_changed(void *section, void *field);
+extern int ucimap_store_section(struct uci_map *map, struct uci_package *p, void *section);
+extern void ucimap_parse(struct uci_map *map, struct uci_package *pkg);
+