summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Nicholson <nicholson@endlessm.com>2017-10-18 16:17:19 +0000
committerAtomic Bot <atomic-devel@projectatomic.io>2017-10-18 16:53:29 +0000
commit3f3d3d64acf0391df3c91b4e3a7c6c7bc5741685 (patch)
tree8e40a3b9af6d6cd8fa402bf95dc1a52f49895293 /Makefile.am
parent18b85fa8bdb2e1b794a3f3ecc56d618c88744f92 (diff)
downloadostree-3f3d3d64acf0391df3c91b4e3a7c6c7bc5741685.tar.gz
build: Do *.am.inc substitutions from make correctly
The string needs to be escaped with a $ since we want to replace the literal string $(path). Without this make will run the command with the value of the variable, which won't match anything in the input Makefile stub. Closes: #1291 Approved by: smcv
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 7f913ab5..2a33282f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -96,7 +96,7 @@ libglnx_libs := $(OT_DEP_GIO_UNIX_LIBS)
# autogen.sh (as we do in Debian, to update the Autotools build system)
# it will try to build it.
$(srcdir)/libglnx/Makefile-libglnx.am.inc: $(srcdir)/libglnx/Makefile-libglnx.am
- sed -e 's,$(libglnx_srcpath),libglnx,g' < $< > $@
+ sed -e 's,$$(libglnx_srcpath),libglnx,g' < $< > $@
include libglnx/Makefile-libglnx.am.inc
EXTRA_DIST += libglnx/Makefile-libglnx.am
noinst_LTLIBRARIES += libglnx.la
@@ -107,7 +107,7 @@ libbsdiff_cflags := $(OT_DEP_GIO_UNIX_CFLAGS) "-I$(bsdiff_srcpath)"
libbsdiff_libs := $(OT_DEP_GIO_UNIX_LIBS)
# See the comment for the similar libglnx bit above
$(srcdir)/bsdiff/Makefile-bsdiff.am.inc: $(srcdir)/bsdiff/Makefile-bsdiff.am
- sed -e 's,$(libbsdiff_srcpath),bsdiff,g' < $< > $@
+ sed -e 's,$$(libbsdiff_srcpath),bsdiff,g' < $< > $@
include bsdiff/Makefile-bsdiff.am.inc
EXTRA_DIST += bsdiff/Makefile-bsdiff.am
noinst_LTLIBRARIES += libbsdiff.la