summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2021-04-15 11:13:31 -0400
committerColin Walters <walters@verbum.org>2021-04-15 12:33:34 -0400
commit46a0911c6d3999e36a10861c94f0c48c033a46f2 (patch)
tree12887858fbe065e71540bb94968005dfd97fab5b /Makefile.am
parent36693f064c63dad550ebcfed33bf9b95806ddef9 (diff)
downloadostree-46a0911c6d3999e36a10861c94f0c48c033a46f2.tar.gz
build-sys: Add toplevel workspace Cargo.toml
rust-analyzer is happier with this because it understands the project structure out of the box. We aren't actually again adding a dependency on Rust/cargo in the core, this is only used to make `cargo build` work out of the box to build the Rust test code.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b2588ad7..2f3cb53f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,6 +46,9 @@ GITIGNOREFILES = aclocal.m4 build-aux/ buildutil/*.m4 config.h.in gtk-doc.make
# Generated by coreos-assembler build-fast and kola
GITIGNOREFILES += fastbuild-*.qcow2 _kola_temp/
+# Rust stuff
+GITIGNOREFILES += target/ Cargo.lock
+
SUBDIRS += .
if ENABLE_GTK_DOC