summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2016-03-31 15:08:45 -0400
committerColin Walters (automation) <walters+githubbot@verbum.org>2016-04-07 12:49:40 +0000
commit984bf91826187140682947fb8e0a2cc0a8a3f355 (patch)
tree285eff2315cf6a4da80472918f70f2f5c0a52214 /Makefile.am
parente81aabba8c4e7c1e773b566f7229d5a3a3d82619 (diff)
downloadostree-984bf91826187140682947fb8e0a2cc0a8a3f355.tar.gz
Use git.mk
It's a lot nicer than manually maintaining .gitignore in general. Closes: #235 Approved by: giuseppe
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e25842d9..488d4b6d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,6 +30,8 @@ AM_CPPFLAGS += -DDATADIR='"$(datadir)"' -DLIBEXECDIR='"$(libexecdir)"' \
AM_CFLAGS += $(WARN_CFLAGS)
DISTCHECK_CONFIGURE_FLAGS += --enable-gtk-doc --disable-maintainer-mode
+GITIGNOREFILES = aclocal.m4 build-aux/ buildutil/*.m4 config.h.in gtk-doc.make
+
SUBDIRS += .
if ENABLE_GTK_DOC
@@ -101,3 +103,5 @@ release-tarball-embedded:
$(embed_dependency) embedded-dependencies/libsoup; \
mv ostree-embeddeps-$${GITVERSION}.tar{.tmp,}; \
gzip -f ostree-embeddeps-$${GITVERSION}.tar
+
+-include $(top_srcdir)/git.mk