summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGiuseppe Scrivano <gscrivan@redhat.com>2015-02-12 16:24:50 +0100
committerColin Walters <walters@verbum.org>2015-03-03 12:16:17 -0500
commita705d9cf29cff0426dc735a0ad562b367a3c5124 (patch)
treef2162ac9f6e8844da96b6f68326978b706936415 /Makefile.am
parent488efac728d660d56e44c88242d0be63a473dea2 (diff)
downloadostree-a705d9cf29cff0426dc735a0ad562b367a3c5124.tar.gz
Add bsdiff submodule
Signed-off-by: Giuseppe Scrivano <gscrivan@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b5b43d6e..c69a7328 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,6 +52,12 @@ libglnx_libs := $(OT_DEP_GIO_UNIX_LIBS)
include libglnx/Makefile-libglnx.am.inc
noinst_LTLIBRARIES += libglnx.la
+libbsdiff_srcpath := $(srcdir)/bsdiff
+libbsdiff_cflags := $(OT_DEP_GIO_UNIX_CFLAGS) "-I$(bsdiff_srcpath)"
+libbsdiff_libs := $(OT_DEP_GIO_UNIX_LIBS)
+include bsdiff/Makefile-bsdiff.am.inc
+noinst_LTLIBRARIES += libbsdiff.la
+
include Makefile-otutil.am
include Makefile-libostree.am
include Makefile-ostree.am