summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDenis Pynkin <denis.pynkin@collabora.com>2019-05-19 16:47:45 +0300
committerAtomic Bot <atomic-devel@projectatomic.io>2019-08-01 02:06:47 +0000
commitca8752e01bdf23650d586a3a5dc6ef04d04cbea6 (patch)
tree4608c5c1db1a3448188a19c80950280529f1fc89 /Makefile.am
parentb7a9c6d07c5e6f252468bac67a42229080d7580a (diff)
downloadostree-ca8752e01bdf23650d586a3a5dc6ef04d04cbea6.tar.gz
build: Conditionally build GPGME-related sources
Do not build GPGME-related sources if flag USE_GPGME is not defined. Signed-off-by: Denis Pynkin <denis.pynkin@collabora.com> Closes: #1889 Approved by: cgwalters
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4850cddd..cd04a055 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,8 +57,10 @@ OT_INTERNAL_SOUP_CFLAGS = $(OT_DEP_SOUP_CFLAGS)
OT_INTERNAL_SOUP_LIBS = $(OT_DEP_SOUP_LIBS)
# This canonicalizes the PKG_CHECK_MODULES or AM_PATH_GPGME results
+if USE_GPGME
OT_INTERNAL_GPGME_CFLAGS = $(OT_DEP_GPGME_CFLAGS) $(GPGME_PTHREAD_CFLAGS)
OT_INTERNAL_GPGME_LIBS = $(OT_DEP_GPGME_LIBS) $(GPGME_PTHREAD_LIBS)
+endif
if BUILDOPT_INTROSPECTION
include $(INTROSPECTION_MAKEFILE)