summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhaedrus Leeds <matthew.leeds@endlessm.com>2020-09-12 14:51:40 -0700
committerPhaedrus Leeds <matthew.leeds@endlessm.com>2020-09-13 10:08:02 -0700
commitc4f26bfdc8e1bba7c01016de5af1e8a84a8b38b0 (patch)
tree30c9b370abbed5dec0122cf6274dd142423c4876 /configure.ac
parent9c040c1a73f6258878905192ba56c46b951f1893 (diff)
downloadostree-c4f26bfdc8e1bba7c01016de5af1e8a84a8b38b0.tar.gz
Avoid shadowing local variablesavoid-shadows
This should help with code readability. Fixes https://github.com/ostreedev/ostree/issues/2194
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c81507d2..de219eab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,7 @@ AS_IF([echo "$CFLAGS" | grep -q -E -e '-Werror($| )'], [], [
CC_CHECK_FLAGS_APPEND([WARN_CFLAGS], [CFLAGS], [\
-pipe \
-Wall \
+ -Werror=shadow \
-Werror=empty-body \
-Werror=strict-prototypes \
-Werror=missing-prototypes \