summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 9607043..6fd9fd3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,9 +68,9 @@ AC_C_BIGENDIAN
AC_HEADER_STDBOOL
if test "$os_unix" = "yes"; then
- AC_CHECK_FUNC([pthread_mutexattr_init], , [
- AC_CHECK_LIB(pthread, pthread_mutexattr_init, , [
- AC_MSG_ERROR([could not find pthread_mutexattr_init])
+ AC_CHECK_FUNC([pthread_create], , [
+ AC_CHECK_LIB(pthread, pthread_create, , [
+ AC_MSG_ERROR([could not find pthread_create])
])
])