summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6015c1e..819b74a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -22,9 +22,17 @@ noinst_PROGRAMS = \
print-messages \
$(CHECK_PROGS)
+cutestfiles = cutest/CuTest.c cutest/CuTest.h
+
+conf_test_SOURCES = conf-test.c $(cutestfiles)
+hash_test_SOURCES = hash-test.c $(cutestfiles)
+pin_test_SOURCES = pin-test.c $(cutestfiles)
+ptr_array_test_SOURCES = ptr-array-test.c $(cutestfiles)
test_init_SOURCES = \
test-init.c \
- mock-module.c mock-module.h
+ mock-module.c mock-module.h $(cutestfiles)
+
+uri_test_SOURCES = uri-test.c $(cutestfiles)
TESTS = $(CHECK_PROGS:=$(EXEEXT))