summaryrefslogtreecommitdiff
path: root/trust/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'trust/tests/Makefile.am')
-rw-r--r--trust/tests/Makefile.am122
1 files changed, 0 insertions, 122 deletions
diff --git a/trust/tests/Makefile.am b/trust/tests/Makefile.am
deleted file mode 100644
index 1f13b2a..0000000
--- a/trust/tests/Makefile.am
+++ /dev/null
@@ -1,122 +0,0 @@
-
-include $(top_srcdir)/build/Makefile.tests
-
-COMMON = $(top_srcdir)/common
-TRUST = $(top_srcdir)/trust
-
-AM_CPPFLAGS = \
- -I$(top_srcdir) \
- -I$(srcdir)/.. \
- -I$(top_srcdir)/p11-kit \
- -I$(COMMON) \
- -DDATADIR=\"$(datadir)\" \
- -DSYSCONFDIR=\"$(sysconfdir)\" \
- -DP11_KIT_FUTURE_UNSTABLE_API \
- $(LIBTASN1_CFLAGS) \
- $(TEST_CFLAGS) \
- $(NULL)
-
-noinst_LTLIBRARIES = \
- libtrust-test.la
-
-libtrust_test_la_SOURCES = \
- test-trust.c test-trust.h \
- $(TRUST)/digest.c
-
-LDADD = \
- $(top_builddir)/trust/libtrust-testable.la \
- $(top_builddir)/trust/libtrust-data.la \
- $(builddir)/libtrust-test.la \
- $(top_builddir)/p11-kit/libp11-kit.la \
- $(top_builddir)/common/libp11-library.la \
- $(top_builddir)/common/libp11-test.la \
- $(top_builddir)/common/libp11-common.la \
- $(LIBTASN1_LIBS) \
- $(HASH_LIBS) \
- $(NULL)
-
-CHECK_PROGS = \
- test-digest \
- test-asn1 \
- test-base64 \
- test-pem \
- test-oid \
- test-utf8 \
- test-x509 \
- test-persist \
- test-index \
- test-parser \
- test-builder \
- test-token \
- test-module \
- test-save \
- test-enumerate \
- test-cer \
- test-bundle \
- test-openssl \
- $(NULL)
-
-noinst_PROGRAMS = \
- frob-pow \
- frob-token \
- frob-nss-trust \
- frob-cert \
- frob-bc \
- frob-ku \
- frob-eku \
- frob-ext \
- frob-cert \
- frob-oid \
- $(CHECK_PROGS)
-
-frob_nss_trust_LDADD = \
- $(top_builddir)/common/libp11-common.la \
- $(top_builddir)/p11-kit/libp11-kit.la \
- $(HASH_LIBS) \
- $(NULL)
-
-TESTS = $(CHECK_PROGS)
-
-EXTRA_DIST = \
- input \
- files \
- $(NULL)
-
-TEST_RUNNER = libtool --mode=execute
-
-test_save_SOURCES = \
- test-save.c \
- $(TRUST)/save.c \
- $(NULL)
-
-test_enumerate_SOURCES = \
- test-enumerate.c \
- $(TRUST)/enumerate.c \
- $(NULL)
-
-test_cer_SOURCES = \
- test-cer.c \
- $(TRUST)/enumerate.c \
- $(TRUST)/extract-cer.c \
- $(TRUST)/save.c \
- $(NULL)
-
-test_bundle_SOURCES = \
- test-bundle.c \
- $(TRUST)/enumerate.c \
- $(TRUST)/extract-pem.c \
- $(TRUST)/save.c \
- $(NULL)
-
-test_openssl_SOURCES = \
- test-openssl.c \
- $(TRUST)/enumerate.c \
- $(TRUST)/extract-openssl.c \
- $(TRUST)/save.c \
- $(NULL)
-
-noinst_SCRIPTS = \
- test-extract
-
-installcheck-local:
- sh $(builddir)/test-extract