summaryrefslogtreecommitdiff
path: root/build/win32/vs10/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2012-08-21 14:07:25 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2012-08-23 21:57:24 +0800
commit635f537ddfe7eccfc2de775f759fb9dfafb51983 (patch)
treed7c17f26e70f4360d95c8c1c03c5b41c656d666e /build/win32/vs10/Makefile.am
parente5333ce32c04a1ddef5c2c6d2b6a414095c2e0ba (diff)
downloadpango-635f537ddfe7eccfc2de775f759fb9dfafb51983.tar.gz
autotools: Re-enable and enhance the completion of MSVC projects
-Isolate the creation of full MSVC projects for pango, pangoft2 and pangocairo in a seperate build/Makefile-msvcproj.am, so it can be included and used elsewhere. -Update the Makefile.am's in pango/ and pango/mini-fribidi to include and use build/Makefile-msvcproj.am to create the MSVC project files -Use templates for the property sheets so that the listings of header files to "install" can be filled in using build/Makefile-msvcproj.am, to simplify future maintenance. -Re-enable the distribution of the created project files and property sheets
Diffstat (limited to 'build/win32/vs10/Makefile.am')
-rw-r--r--build/win32/vs10/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/build/win32/vs10/Makefile.am b/build/win32/vs10/Makefile.am
index 310ac283..b52f9f19 100644
--- a/build/win32/vs10/Makefile.am
+++ b/build/win32/vs10/Makefile.am
@@ -1,16 +1,33 @@
EXTRA_DIST = \
pango.sln \
pango_fc.sln \
+ pango.propsin \
pango.props \
+ pango.vcxproj \
+ pango.vcxproj.filters \
pango.vcxprojin \
pango.vcxproj.filtersin \
+ pangoft2.vcxproj \
+ pangoft2.vcxproj.filters \
pangoft2.vcxprojin \
pangoft2.vcxproj.filtersin \
+ pangowin32.vcxproj \
+ pangowin32.vcxproj.filters \
+ pangocairo.vcxproj \
+ pangocairo.vcxproj.filters \
pangocairo.vcxprojin \
pangocairo.vcxproj.filtersin \
+ pangocairo_fc.vcxproj \
+ pangocairo_fc.vcxproj.filters \
pangocairo_fc.vcxprojin \
pangocairo_fc.vcxproj.filtersin \
install.vcxproj \
README.txt
+pango.props: $(top_srcdir)/build/win32/vs10/pango.propsin pango.vs10.headers
+ $(CPP) -P - <$(top_srcdir)/build/win32/vs10/pango.propsin >$@
+ rm pango.vs10.headers
+
+DISTCLEANFILES = pango.props
+
-include $(top_srcdir)/git.mk