summaryrefslogtreecommitdiff
path: root/build/win32/vs9/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2014-01-10 16:58:38 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2014-01-10 16:58:38 +0800
commitc825bb054b38d0cc78f878d115189ff32a4773a2 (patch)
tree870cc91d0f747d7066e8ba671710847bcb9ea40c /build/win32/vs9/Makefile.am
parenta6c318ee505aeabe6f84e1543d68834b9e0e7acf (diff)
downloadpango-c825bb054b38d0cc78f878d115189ff32a4773a2.tar.gz
MSVC Builds: Rework Introspection Build
The current approach of building the introspection files for Pango works, but is often cumbersome as one needs to set many environmental variables before launching a solution file, which runs a Windows batch script to generate the .gir/.typelib files. It was also possible to hand-run the batch script from the Visual Studio command prompt, but even more environmental variables need to be set. This changes the approach to build the introspection files using an NMake Makefile (but elimating from the Visual Studio Project Files the part to build the introspection files) to: -Make it clearer to the person building the introspection files what environmental variables are needed, specifically for PKG_CONFIG_PATH and MINGWDIR and CFG (formerly CONF). Setting stuff like VSVER, PLAT and BASEDIR is no longer required, which was a bit clunky. -Allows some more easier flexibility on the build of the intropsection files.
Diffstat (limited to 'build/win32/vs9/Makefile.am')
-rw-r--r--build/win32/vs9/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/build/win32/vs9/Makefile.am b/build/win32/vs9/Makefile.am
index eb8189bb..71b6a7f0 100644
--- a/build/win32/vs9/Makefile.am
+++ b/build/win32/vs9/Makefile.am
@@ -1,7 +1,6 @@
EXTRA_DIST = \
pango.sln \
pango-build-defines.vsprops \
- pango-gengir.vsprops \
pango-ignore-fc.vsprops \
pango-install-bin.vsprops \
pango-install.vsprops \
@@ -17,7 +16,6 @@ EXTRA_DIST = \
pangowin32.vcproj \
install.vcproj \
stdint.h \
- gengir.vcproj \
README.txt
pango-install.vsprops: $(top_srcdir)/build/win32/vs9/pango-install.vspropsin pango.vs9.headers