summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2014-07-26 16:27:59 -0400
committerBehdad Esfahbod <behdad@behdad.org>2014-07-26 16:27:59 -0400
commit40f5c151e911464cb9da569d8ceee88f52fcbfbf (patch)
tree56d4275d3ea25150b43e7f259a145c3dad84c234 /configure.ac
parentb30a04708823c14fc9fef81294bfb2b87ac5df7a (diff)
downloadpango-40f5c151e911464cb9da569d8ceee88f52fcbfbf.tar.gz
[fc] Use FcWeightTo/FromOpenType() if available
This makes the weight mapping a continuous, as ooposed to a step function. Last piece of Bug 733764 - Support more / free font weights
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 34e0eb9b..77c6291c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -224,6 +224,12 @@ have_fontconfig=false
if $have_harfbuzz ; then
PKG_CHECK_MODULES(FONTCONFIG, fontconfig >= 2.10.91, have_fontconfig=true, AC_MSG_RESULT([no]))
fi
+if $have_fontconfig ; then
+ pango_save_libs=$LIBS
+ LIBS="$LIBS $FONTCONFIG_LIBS"
+ AC_CHECK_FUNCS(FcWeightFromOpenType)
+ LIBS=$pango_save_libs
+fi
#
# Checks for FreeType