summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2017-02-15 13:25:59 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2017-02-15 13:25:59 +0800
commita0239aec27aa04a234ab6683994b304d197d7035 (patch)
treea6dfa51498035289a0bcebbd0382eb0efa59d1d1 /configure.ac
parente4ea2d2e5118b44bf1c3e5fa998356696e073aa8 (diff)
downloadpango-a0239aec27aa04a234ab6683994b304d197d7035.tar.gz
Visual Studio builds: Support Visual Studio 2017
This updates the autotools scripts to support Visual Studio 2017 builds, by copying the Visual Studio 2010 projects and updating items in there as necessary. Note the format of the toolset version changed, so we allow one to specify a custom toolset version string and hence use it if it is specified, otherwise the toolset version string is generated as it was before. Since Visual Studio 2017 aims to be compatible on the CRT level as Visual Studio 2015, the 2017-compiled binaries should be usable without problems with 2015-compiled binaries.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ed1a0053..c6b67c90 100644
--- a/configure.ac
+++ b/configure.ac
@@ -594,6 +594,10 @@ AC_SUBST(PANGO_HIDDEN_VISIBILITY_CFLAGS)
AC_HEADER_DIRENT
AC_CHECK_HEADERS(unistd.h)
+# Check whether MSVC toolset is explicitly set
+AM_CONDITIONAL(MSVC_BASE_NO_TOOLSET_SET, [test x$MSVC_BASE_TOOLSET = x])
+AM_CONDITIONAL(MSVC_NO_TOOLSET_SET, [test x$MSVC_TOOLSET = x])
+
# Honor aclocal flags
ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
dnl ===========================================================================
@@ -653,6 +657,7 @@ win32/vs10/pango-version-paths.props
win32/vs11/Makefile
win32/vs12/Makefile
win32/vs14/Makefile
+win32/vs15/Makefile
pango.pc
pangowin32.pc
pangoft2.pc