summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKhaled Hosny <khaledhosny@eglug.org>2018-04-11 13:52:07 +0200
committerKhaled Hosny <khaledhosny@eglug.org>2018-04-11 13:52:07 +0200
commit63e1fc9b23b4f0e8eaacd151ad39403eaa2b48ef (patch)
tree999cbe0dc28e7627f7e44b77ad04d18bf6a2f330 /configure.ac
parent5d46e21df66a11233186ddf27ca8c70149307871 (diff)
downloadpango-63e1fc9b23b4f0e8eaacd151ad39403eaa2b48ef.tar.gz
Use non-deprecated libthai API when available
I’m assuming the new API is thread-safe as claimed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index be20dce3..5e879a82 100644
--- a/configure.ac
+++ b/configure.ac
@@ -487,6 +487,10 @@ have_libthai=false
PKG_CHECK_MODULES(LIBTHAI, libthai >= $LIBTHAI_REQUIRED_VERSION, have_libthai=true, :)
if $have_libthai; then
AC_DEFINE(HAVE_LIBTHAI, 1, [Whether libthai is available])
+ pango_save_libs=$LIBS
+ LIBS="$LIBS $LIBTHAI_LIBS"
+ AC_CHECK_FUNCS(th_brk_find_breaks)
+ LIBS=$pango_save_libs
fi
#