summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2010-02-10 15:30:12 +0200
committerTor Lillqvist <tml@iki.fi>2010-03-15 23:25:26 +0200
commitb68d520e9ff526be4301f6db09c0faa077cd864a (patch)
tree2a5d959733f966f72b0b128799fa35b184b0ddf4 /configure.in
parent6118d5891fee776a087855c335a73c79fdaf036c (diff)
downloadpango-b68d520e9ff526be4301f6db09c0faa077cd864a.tar.gz
Add solution and project files for Visual Studio builds
The VS files are kept in build/win32/vs9, the same relative location as in GLib, mostly for historical reasons. Update README.win32 to reflect the VS possibility. Include the VS solution and project files in the tarball when doing a release. To avoid having to list source files in several locations, generate files listing source files at "make dist" time in the corresponding source directories. Use the C preprocessor to preprocess .vcprojin files that include said list files into the actual .vcproj project files. Provide a rc file for the pangocairo DLL, too. Construct and provide in the tarball a pregenerated config.h.win32 which can be used as config.h when building with Visual C without running any configure script. Provide pregenerarated module-defs.h.win32, module-defs-lang.c.win32 files too. Define PANGO_MODULE_PREFIX appropriately in the relevant module source files if not available from the compilation command line. Update module-defs-fc.c.win32 and module-defs-win32.c.win32 to match what the configure script provides.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 8e2bebc5..2e03066a 100644
--- a/configure.in
+++ b/configure.in
@@ -758,9 +758,9 @@ for module in $included_modules; do
module_c=`echo $module | sed s/-/_/`
cat >> pango/module-defs.h <<EOTEXT
extern void _pango_${module_c}_script_engine_list (PangoEngineInfo **engines, int *n_engines);
-extern PangoEngine *_pango_${module_c}_script_engine_init (GTypeModule *module);
+extern void _pango_${module_c}_script_engine_init (GTypeModule *module);
extern void _pango_${module_c}_script_engine_exit (void);
-extern void _pango_${module_c}_script_engine_create (const char *id);
+extern PangoEngine *_pango_${module_c}_script_engine_create (const char *id);
EOTEXT
done
@@ -963,6 +963,7 @@ pango/opentype/Makefile
pango/pango.rc
pango/pangoft2.rc
pango/pangowin32.rc
+pango/pangocairo.rc
pango/pangox.rc
pango/pangoxft.rc
pango-view/Makefile
@@ -981,6 +982,9 @@ docs/Makefile
docs/version.xml
tools/Makefile
tests/Makefile
+build/Makefile
+build/win32/Makefile
+build/win32/vs9/Makefile
pango.pc
pangox.pc
pangowin32.pc
@@ -994,6 +998,7 @@ pangoft2-uninstalled.pc
pangoxft-uninstalled.pc
pangocairo-uninstalled.pc
pango-zip.sh
+config.h.win32
])
AC_CONFIG_FILES([tests/runtests.sh],