summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2012-08-20 16:06:39 -0400
committerBehdad Esfahbod <behdad@behdad.org>2012-08-20 16:07:36 -0400
commit2bf13b81e9f9e019f800ed380c27097d7abf5869 (patch)
treea3e7ac2a5f94fb2e20d12348c97e41b73a276719 /configure.in
parent023df214ba97ce79222be678f8fa532249eb1ab6 (diff)
downloadpango-2bf13b81e9f9e019f800ed380c27097d7abf5869.tar.gz
Make HarfBuzz dependency optional (on non-Linux), update README
If HarfBuzz is not available, we just can't build the Freetype/Fontconfig backend...
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 030f5d92..f64046e1 100644
--- a/configure.in
+++ b/configure.in
@@ -433,8 +433,12 @@ AM_CONDITIONAL(HAVE_CAIRO_QUARTZ, $have_cairo_quartz)
harfbuzz_required=0.9
have_harfbuzz=false
-PKG_CHECK_MODULES(HARFBUZZ, harfbuzz >= $harfbuzz_required, have_harfbuzz=true)
+PKG_CHECK_MODULES(HARFBUZZ, harfbuzz >= $harfbuzz_required, have_harfbuzz=true, have_harfbuzz=false)
AM_CONDITIONAL(HAVE_HARFBUZZ, $have_harfbuzz)
+if ! $have_harfbuzz; then
+ have_freetype=false
+ have_xft=false
+fi
#
# We must have some backend defined, in order for the pango-querymodules
@@ -443,7 +447,7 @@ AM_CONDITIONAL(HAVE_HARFBUZZ, $have_harfbuzz)
# patch to fix that rule. :-)
#
if $have_freetype || $have_xft || $have_cairo || $have_win32 ; then : ; else
- AC_MSG_ERROR([*** Could not enable any of FreeType, Xft, Cairo, or Win32 backends.
+ AC_MSG_ERROR([*** Could not enable any backends.
*** Must have at least one backend to build Pango.])
fi