summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2012-08-16 21:58:44 -0400
committerBehdad Esfahbod <behdad@behdad.org>2012-08-16 22:02:45 -0400
commit7c6c11cd8392d483f0de7bba434faccdb9c068fa (patch)
treef48f5013a5da1a3c106110ac6ec5e2de715c3769 /configure.in
parent194b6ee552318ec6c494f34ed9f0979d0460fe4f (diff)
downloadpango-7c6c11cd8392d483f0de7bba434faccdb9c068fa.tar.gz
Remove Atsui Module
CoreText for the win.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in56
1 files changed, 7 insertions, 49 deletions
diff --git a/configure.in b/configure.in
index 90ed3c46..9e26921c 100644
--- a/configure.in
+++ b/configure.in
@@ -317,11 +317,6 @@ if test "$pango_os_win32" = "yes"; then
fi
#
-# Checks for ATSUI
-#
-AC_CHECK_HEADER(Carbon/Carbon.h, [have_atsui=true], [have_atsui=false])
-
-#
# Checks for CoreText
#
@@ -350,7 +345,7 @@ have_cairo_pdf=false
have_cairo_xlib=false
have_cairo_freetype=false
have_cairo_win32=false
-have_cairo_atsui=false
+have_cairo_quartz=false
cairo_required=1.7.6
PKG_CHECK_MODULES(CAIRO, cairo >= $cairo_required, have_cairo=true, AC_MSG_RESULT([no]))
@@ -382,11 +377,11 @@ if $have_cairo ; then
have_cairo=true
fi
- if test $have_atsui -o $have_core_text; then
- PKG_CHECK_EXISTS(cairo-quartz-font >= $cairo_required, have_cairo_atsui=true, :)
+ if test $have_core_text; then
+ PKG_CHECK_EXISTS(cairo-quartz-font >= $cairo_required, have_cairo_quartz=true, :)
fi
- if $have_cairo_atsui; then
- AC_DEFINE(HAVE_CAIRO_ATSUI, 1, [Whether Cairo can use ATSUI for fonts])
+ if $have_cairo_quartz; then
+ AC_DEFINE(HAVE_CAIRO_QUARTZ, 1, [Whether Cairo can use Quartz for fonts])
cairo_font_backends="quartz $cairo_font_backends"
have_cairo=true
fi
@@ -434,7 +429,7 @@ AM_CONDITIONAL(HAVE_CAIRO_PDF, $have_cairo_pdf)
AM_CONDITIONAL(HAVE_CAIRO_XLIB, $have_cairo_xlib)
AM_CONDITIONAL(HAVE_CAIRO_WIN32, $have_cairo_win32)
AM_CONDITIONAL(HAVE_CAIRO_FREETYPE, $have_cairo_freetype)
-AM_CONDITIONAL(HAVE_CAIRO_ATSUI, $have_cairo_atsui)
+AM_CONDITIONAL(HAVE_CAIRO_QUARTZ, $have_cairo_quartz)
harfbuzz_required=0.9
@@ -489,7 +484,7 @@ GOBJECT_INTROSPECTION_CHECK([0.9.5])
# Modules to build
#
arabic_modules="arabic-lang"
-basic_modules="basic-fc,basic-win32,basic-x,basic-atsui,basic-coretext"
+basic_modules="basic-fc,basic-win32,basic-x,basic-coretext"
indic_modules="indic-lang"
thai_modules=""
@@ -536,17 +531,13 @@ AC_MSG_RESULT([$dynamic_modules (those built into Pango will be excluded)])
AM_CONDITIONAL(HAVE_DYNAMIC_MODULES, test "x$dynamic_modules" != x)
-INCLUDED_X_MODULES=
INCLUDED_FC_MODULES=
INCLUDED_WIN32_MODULES=
-INCLUDED_ATSUI_MODULES=
INCLUDED_CORE_TEXT_MODULES=
INCLUDED_LANG_MODULES=
-AC_SUBST(INCLUDED_X_MODULES)
AC_SUBST(INCLUDED_FC_MODULES)
AC_SUBST(INCLUDED_WIN32_MODULES)
-AC_SUBST(INCLUDED_ATSUI_MODULES)
AC_SUBST(INCLUDED_CORE_TEXT_MODULES)
AC_SUBST(INCLUDED_LANG_MODULES)
@@ -556,10 +547,8 @@ for module in $included_modules; do
included_path="\$(top_builddir)/modules/$dir/libpango-$module.la"
case $module in
- *-x) INCLUDED_X_MODULES="$INCLUDED_X_MODULES $included_path" ;;
*-fc) INCLUDED_FC_MODULES="$INCLUDED_FC_MODULES $included_path" ;;
*-win32) INCLUDED_WIN32_MODULES="$INCLUDED_WIN32_MODULES $included_path" ;;
- *-atsui) INCLUDED_ATSUI_MODULES="$INCLUDED_ATSUI_MODULES $included_path" ;;
*-coretext) INCLUDED_CORE_TEXT_MODULES="$INCLUDED_CORE_TEXT_MODULES $included_path" ;;
*-lang) INCLUDED_LANG_MODULES="$INCLUDED_LANG_MODULES $included_path" ;;
*) IFS="$pango_save_ifs"; AC_MSG_ERROR([specified module $module not recognized]) ;;
@@ -571,7 +560,6 @@ AM_CONDITIONAL(INCLUDE_ARABIC_LANG, echo $included_modules | egrep '(^|,)arabic-
AM_CONDITIONAL(INCLUDE_BASIC_FC, echo $included_modules | egrep '(^|,)basic-fc($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_BASIC_WIN32, echo $included_modules | egrep '(^|,)basic-win32($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_BASIC_X, echo $included_modules | egrep '(^|,)basic-x($|,)' > /dev/null)
-AM_CONDITIONAL(INCLUDE_BASIC_ATSUI, echo $included_modules | egrep '(^|,)basic-atsui($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_BASIC_CORE_TEXT, echo $included_modules | egrep '(^|,)basic-coretext($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_INDIC_LANG, echo $included_modules | egrep '(^|,)indic-lang($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_THAI_LANG, echo $included_modules | egrep '(^|,)thai-lang($|,)' > /dev/null)
@@ -580,7 +568,6 @@ AM_CONDITIONAL(DYNAMIC_ARABIC_LANG, echo $dynamic_modules | egrep '(^|,)arabic-l
AM_CONDITIONAL(DYNAMIC_BASIC_FC, echo $dynamic_modules | egrep '(^|,)basic-fc($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_BASIC_WIN32, echo $dynamic_modules | egrep '(^|,)basic-win32($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_BASIC_X, echo $dynamic_modules | egrep '(^|,)basic-x($|,)' > /dev/null)
-AM_CONDITIONAL(DYNAMIC_BASIC_ATSUI, echo $dynamic_modules | egrep '(^|,)basic-atsui($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_BASIC_CORE_TEXT, echo $dynamic_modules | egrep '(^|,)basic-coretext($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_INDIC_LANG, echo $dynamic_modules | egrep '(^|,)indic-lang($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_THAI_LANG, echo $dynamic_modules | egrep '(^|,)thai-lang($|,)' > /dev/null)
@@ -840,35 +827,6 @@ cat >> pango/module-defs-win32.c <<EOTEXT
EOTEXT
])
-AC_CONFIG_COMMANDS([pango/module-defs-atsui.c],
-[
-### ATSUI modules
-cat > pango/module-defs-atsui.c <<EOTEXT
-/* Autogenerated by configure. Do not edit */
-
-#include "module-defs.h"
-
-PangoIncludedModule _pango_included_atsui_modules@<:@@:>@ = {
-EOTEXT
-
-IFS="${IFS= }"; pango_save_ifs="$IFS"; IFS=","
-for module in $included_modules; do
- if echo $module | egrep -- "-atsui($|,)" > /dev/null; then
- module_c=`echo $module | sed s/-/_/`
- cat >> pango/module-defs-atsui.c <<EOTEXT
- { _pango_${module_c}_script_engine_list, _pango_${module_c}_script_engine_init, _pango_${module_c}_script_engine_exit, _pango_${module_c}_script_engine_create },
-EOTEXT
- fi
-done
-
-IFS="$pango_save_ifs"
-
-cat >> pango/module-defs-atsui.c <<EOTEXT
- { NULL, NULL, NULL, NULL },
-};
-EOTEXT
-])
-
AC_CONFIG_COMMANDS([pango/module-defs-coretext.c],
[
### CoreText modules