summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2012-08-16 20:51:57 -0400
committerBehdad Esfahbod <behdad@behdad.org>2012-08-16 21:10:10 -0400
commit8168660e5f1906aed2a45d30529058f51473bcef (patch)
tree8c5a9172672404c0f85bc78f3ba31a566cb52aba /configure.in
parentfeff5a6e2682048a07a6ba09af83254e290bf394 (diff)
parent656d473b52e3edea621c0681d2ba14363f257e84 (diff)
downloadpango-8168660e5f1906aed2a45d30529058f51473bcef.tar.gz
Merge branch 'harfbuzz-ng-external'
Conflicts: configure.in docs/tmpl/text-attributes.sgml modules/arabic/arabic-ot.c modules/indic/indic-ot.c pango/opentype/Makefile.am pango/opentype/hb-blob.c pango/opentype/hb-buffer-private.h pango/opentype/hb-common.h pango/opentype/hb-ot-layout-gsubgpos-private.hh pango/opentype/hb-private.h pango/pango-ot-info.c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in53
1 files changed, 14 insertions, 39 deletions
diff --git a/configure.in b/configure.in
index 83622802..fc5a0f76 100644
--- a/configure.in
+++ b/configure.in
@@ -369,7 +369,7 @@ have_cairo_atsui=false
cairo_required=1.7.6
PKG_CHECK_MODULES(CAIRO, cairo >= $cairo_required, have_cairo=true, AC_MSG_RESULT([no]))
-
+
if $have_cairo ; then
pango_save_libs=$LIBS
LIBS="$LIBS $CAIRO_LIBS"
@@ -451,6 +451,12 @@ AM_CONDITIONAL(HAVE_CAIRO_WIN32, $have_cairo_win32)
AM_CONDITIONAL(HAVE_CAIRO_FREETYPE, $have_cairo_freetype)
AM_CONDITIONAL(HAVE_CAIRO_ATSUI, $have_cairo_atsui)
+
+harfbuzz_required=0.9
+have_harfbuzz=false
+PKG_CHECK_MODULES(HARFBUZZ, harfbuzz >= $harfbuzz_required, have_harfbuzz=true)
+AM_CONDITIONAL(HAVE_HARFBUZZ, $have_harfbuzz)
+
#
# We must have some backend defined, in order for the pango-querymodules
# rule in pango/Makefile.am to work correctly. If you are up to writing
@@ -485,9 +491,8 @@ GLIB_CFLAGS=`$PKG_CONFIG --cflags $GLIB_MODULES gthread-2.0`
#
# Checks for LibThai
#
-have_libthai=false
LIBTHAI_REQUIRED_VERSION=0.1.9
-PKG_CHECK_MODULES(LIBTHAI, libthai >= $LIBTHAI_REQUIRED_VERSION, have_libthai=true, :)
+PKG_CHECK_MODULES(LIBTHAI, libthai >= $LIBTHAI_REQUIRED_VERSION, have_libthai=true, have_libthai=false)
#
# Checks for GObject Introspection
@@ -498,21 +503,16 @@ GOBJECT_INTROSPECTION_CHECK([0.9.5])
#
# Modules to build
#
-arabic_modules="arabic-fc,arabic-lang"
+arabic_modules="arabic-lang"
basic_modules="basic-fc,basic-win32,basic-x,basic-atsui,basic-coretext"
-hangul_modules="hangul-fc"
-hebrew_modules="hebrew-fc"
-indic_modules="indic-fc,indic-lang"
-khmer_modules="khmer-fc"
-syriac_modules="syriac-fc"
-thai_modules="thai-fc"
-tibetan_modules="tibetan-fc"
+indic_modules="indic-lang"
+thai_modules=""
if $have_libthai ; then
thai_modules="$thai_modules,thai-lang"
fi
-all_modules="$arabic_modules,$basic_modules,$hangul_modules,$hebrew_modules,$indic_modules,$khmer_modules,$syriac_modules,$thai_modules,$tibetan_modules"
+all_modules="$arabic_modules,$basic_modules,$indic_modules,$thai_modules"
#
# Allow building some or all modules included
@@ -567,10 +567,7 @@ AC_SUBST(INCLUDED_LANG_MODULES)
IFS="${IFS= }"; pango_save_ifs="$IFS"; IFS=", "
for module in $included_modules; do
- case $indic_modules in
- *$module*) dir=indic ;;
- *) dir=`echo $module | sed "s/-.*//"` ;;
- esac
+ dir=`echo $module | sed "s/-.*//"`
included_path="\$(top_builddir)/modules/$dir/libpango-$module.la"
case $module in
@@ -585,39 +582,23 @@ for module in $included_modules; do
done
IFS="$pango_save_ifs"
-AM_CONDITIONAL(INCLUDE_ARABIC_FC, echo $included_modules | egrep '(^|,)arabic-fc($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_ARABIC_LANG, echo $included_modules | egrep '(^|,)arabic-lang($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_BASIC_FC, echo $included_modules | egrep '(^|,)basic-fc($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_BASIC_WIN32, echo $included_modules | egrep '(^|,)basic-win32($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_BASIC_X, echo $included_modules | egrep '(^|,)basic-x($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_BASIC_ATSUI, echo $included_modules | egrep '(^|,)basic-atsui($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_BASIC_CORE_TEXT, echo $included_modules | egrep '(^|,)basic-coretext($|,)' > /dev/null)
-AM_CONDITIONAL(INCLUDE_HANGUL_FC, echo $included_modules | egrep '(^|,)hangul-fc($|,)' > /dev/null)
-AM_CONDITIONAL(INCLUDE_HEBREW_FC, echo $included_modules | egrep '(^|,)hebrew-fc($|,)' > /dev/null)
-AM_CONDITIONAL(INCLUDE_INDIC_FC, echo $included_modules | egrep '(^|,)indic-fc($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_INDIC_LANG, echo $included_modules | egrep '(^|,)indic-lang($|,)' > /dev/null)
-AM_CONDITIONAL(INCLUDE_KHMER_FC, echo $included_modules | egrep '(^|,)khmer-fc($|,)' > /dev/null)
-AM_CONDITIONAL(INCLUDE_SYRIAC_FC, echo $included_modules | egrep '(^|,)syriac-fc($|,)' > /dev/null)
-AM_CONDITIONAL(INCLUDE_THAI_FC, echo $included_modules | egrep '(^|,)thai-fc($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_THAI_LANG, echo $included_modules | egrep '(^|,)thai-lang($|,)' > /dev/null)
-AM_CONDITIONAL(INCLUDE_TIBETAN_FC, echo $included_modules | egrep '(^|,)tibetan-fc($|,)' > /dev/null)
-AM_CONDITIONAL(DYNAMIC_ARABIC_FC, echo $dynamic_modules | egrep '(^|,)arabic-fc($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_ARABIC_LANG, echo $dynamic_modules | egrep '(^|,)arabic-lang($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_BASIC_FC, echo $dynamic_modules | egrep '(^|,)basic-fc($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_BASIC_WIN32, echo $dynamic_modules | egrep '(^|,)basic-win32($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_BASIC_X, echo $dynamic_modules | egrep '(^|,)basic-x($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_BASIC_ATSUI, echo $dynamic_modules | egrep '(^|,)basic-atsui($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_BASIC_CORE_TEXT, echo $dynamic_modules | egrep '(^|,)basic-coretext($|,)' > /dev/null)
-AM_CONDITIONAL(DYNAMIC_HANGUL_FC, echo $dynamic_modules | egrep '(^|,)hangul-fc($|,)' > /dev/null)
-AM_CONDITIONAL(DYNAMIC_HEBREW_FC, echo $dynamic_modules | egrep '(^|,)hebrew-fc($|,)' > /dev/null)
-AM_CONDITIONAL(DYNAMIC_INDIC_FC, echo $dynamic_modules | egrep '(^|,)indic-fc($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_INDIC_LANG, echo $dynamic_modules | egrep '(^|,)indic-lang($|,)' > /dev/null)
-AM_CONDITIONAL(DYNAMIC_KHMER_FC, echo $dynamic_modules | egrep '(^|,)khmer-fc($|,)' > /dev/null)
-AM_CONDITIONAL(DYNAMIC_SYRIAC_FC, echo $dynamic_modules | egrep '(^|,)syriac-fc($|,)' > /dev/null)
-AM_CONDITIONAL(DYNAMIC_THAI_FC, echo $dynamic_modules | egrep '(^|,)thai-fc($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_THAI_LANG, echo $dynamic_modules | egrep '(^|,)thai-lang($|,)' > /dev/null)
-AM_CONDITIONAL(DYNAMIC_TIBETAN_FC, echo $dynamic_modules | egrep '(^|,)tibetan-fc($|,)' > /dev/null)
#
# We use flockfile to implement pango_getline() - should be moved to GLib
@@ -683,7 +664,7 @@ dnl * Options to pass to libtool
dnl ********************************************************
# Note that -module isn't included here since automake needs to see it to know
-# that something like pango-arabic-fc.la is a valid libtool archive
+# that something like pango-basic-fc.la is a valid libtool archive
#
LIBRARY_LIBTOOL_OPTIONS="-version-info $VERSION_INFO"
MODULE_LIBTOOL_OPTIONS="-export-dynamic -avoid-version"
@@ -1005,7 +986,6 @@ AC_CONFIG_FILES([
Makefile
pango/Makefile
pango/mini-fribidi/Makefile
-pango/opentype/Makefile
pango/pango.rc
pango/pangoft2.rc
pango/pangowin32.rc
@@ -1016,13 +996,8 @@ pango-view/Makefile
modules/Makefile
modules/arabic/Makefile
modules/basic/Makefile
-modules/hangul/Makefile
-modules/hebrew/Makefile
modules/indic/Makefile
-modules/khmer/Makefile
-modules/syriac/Makefile
modules/thai/Makefile
-modules/tibetan/Makefile
examples/Makefile
docs/Makefile
docs/version.xml