summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2000-06-21 16:13:42 +0000
committerOwen Taylor <otaylor@src.gnome.org>2000-06-21 16:13:42 +0000
commit0e6409a158d9dd76a31b9eccf7c4f26c5466d082 (patch)
treedc120946f7efa23c6c91c64aee2686d2637e3970 /configure.in
parent197a2a68c145d3568cd4f0f2fee3d3b55570134f (diff)
downloadpango-0e6409a158d9dd76a31b9eccf7c4f26c5466d082.tar.gz
Remove tests for libunicode
Wed Jun 21 12:11:56 2000 Owen Taylor <otaylor@redhat.com> * configure.in: Remove tests for libunicode * pango/utils.[ch]: Removed. The functions from here are now in GLib. * **.[ch]: Removed use of libunicode and utils.c in favor of Unicode functions in GLib. Requires latest GLib from CVS.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 6 insertions, 16 deletions
diff --git a/configure.in b/configure.in
index 29ec4dca..1019c79a 100644
--- a/configure.in
+++ b/configure.in
@@ -33,7 +33,7 @@ if test x$FRIBIDI_CONFIG = xno ; then
AC_MSG_ERROR([*** fribidi-config not found])
fi
FRIBIDI_CFLAGS="`$FRIBIDI_CONFIG --cflags`"
-CFLAGS="$CFLAGS $UNICODE_CFLAGS"
+CFLAGS="$CFLAGS $FRIBIDI_CFLAGS"
FRIBIDI_LIBS="`$FRIBIDI_CONFIG --libs`"
AC_SUBST(FRIBIDI_LIBS)
AC_SUBST(FRIBIDI_CFLAGS)
@@ -53,20 +53,6 @@ AC_SUBST(GLIB_LIBS)
AC_SUBST(GLIB_CFLAGS)
-AC_PATH_PROG(UNICODE_CONFIG, unicode-config, no)
-if test x$UNICODE_CONFIG = xno ; then
- AC_MSG_ERROR([*** unicode-config not found])
-fi
-UNICODE_CFLAGS="`$UNICODE_CONFIG --cflags`"
-CFLAGS="$CFLAGS $UNICODE_CFLAGS"
-UNICODE_LIBS="`$UNICODE_CONFIG --libs`"
-AC_SUBST(UNICODE_LIBS)
-AC_SUBST(UNICODE_CFLAGS)
-
-AC_CHECK_LIB(unicode, unicode_type, :,
- AC_MSG_ERROR([*** libunicode not found.]), $UNICODE_LIBS)
-
-
#
# Checks for iconv
#
@@ -92,9 +78,13 @@ if test "x$found_iconv" = "xno" ; then
AC_MSG_ERROR([*** No iconv() implementation found in C library or libiconv])
fi
+UNICODE_CFLAGS=
+UNICODE_LIBS=
if test "x$with_libiconv" = "xyes" ; then
- UNICODE_LIBS="$UNICODE_LIBS -liconv"
+ UNICODE_LIBS="-liconv"
fi
+AC_SUBST(UNICODE_CFLAGS)
+AC_SUBST(UNICODE_LIBS)
#
# Allow building some or all modules included