summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2000-12-18 18:58:24 +0000
committerHavoc Pennington <hp@src.gnome.org>2000-12-18 18:58:24 +0000
commit1a603d00f370167b75a965416080f45824d5b515 (patch)
tree6023e2c3a5b27341215e51d50823ef8d559ac068 /configure.in
parentcf11e920312b335c5eaa21021a1176fe9f913d9b (diff)
downloadpango-1a603d00f370167b75a965416080f45824d5b515.tar.gz
Fix build breakage, reported by Alex Larsson and Yasushi Shoji
2000-12-18 Havoc Pennington <hp@redhat.com> Fix build breakage, reported by Alex Larsson and Yasushi Shoji * pango/pangox.h: don't include pango.h, just individual headers * configure.in: check for perl, add --disable-rebuilds configure option, automatically disable rebuilds if no perl * pango/Makefile.am: use located perl to run makeenums.pl, and don't try to rebuild if we did --disable-rebuilds (EXTRA_DIST): add built headers * modules/*/*.[hc]: don't include pango.h, include specific headers
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a4cffeeb..a3dd9f5b 100644
--- a/configure.in
+++ b/configure.in
@@ -25,6 +25,21 @@ changequote([,])dnl
AC_PATH_XTRA
+AC_ARG_ENABLE(rebuilds, [ --disable-rebuilds disable all source autogeneration rules],,enable_rebuilds=yes)
+
+# define a MAINT-like variable REBUILD which is set if Perl
+# is found, so autogenerated sources can be rebuilt
+
+AC_CHECK_PROGS(PERL, perl5 perl)
+
+REBUILD=\#
+if test "x$enable_rebuilds" = "xyes" && \
+ test -n "$PERL" && \
+ $PERL -e 'exit !($] >= 5.002)' > /dev/null 2>&1 ; then
+ REBUILD=
+fi
+AC_SUBST(REBUILD)
+
if test x$no_x = xyes ; then
AC_MSG_ERROR([X development libraries not found])
fi