summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2000-05-28 15:52:25 +0000
committerOwen Taylor <otaylor@src.gnome.org>2000-05-28 15:52:25 +0000
commit45a1d90a3a453950f74bada5c5337554cb596062 (patch)
treee48eacb949402aab82269bed5fec6de06dac0e5b /configure.in
parent1c7a5a30d5896a79a4a0c806b43a2db7e4bcc4f8 (diff)
downloadpango-45a1d90a3a453950f74bada5c5337554cb596062.tar.gz
Since we require GLib-1.3, and thus can no longer build the examples
Sun May 28 16:24:43 2000 Owen Taylor <otaylor@redhat.com> * examples/Makefile.am examples/viewer-qt.cc examples/viewer-qt.h: Since we require GLib-1.3, and thus can no longer build the examples against GTK+-1.2, and since there is a nasty circular dependency if we build examples against GTK+-1.3, rewrite (optional) example program in Qt. (I wasn't going to do it in Xaw or straight Xlib...) * configure.in: Added checks for Qt. * pango/pango-layout.h: Fix constness.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in52
1 files changed, 46 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 57a7c934..4fb3eb18 100644
--- a/configure.in
+++ b/configure.in
@@ -24,12 +24,9 @@ fi
X_LIBS="-L$x_libraries -lX11"
AC_SUBST(X_LIBS)
-gtk_works=no
-AM_PATH_GTK(1.2.0,
- [CFLAGS="$GTK_CFLAGS $CFLAGS"; gtk_works=yes],
- AC_MSG_WARN("Disabling GTK+-based tests"))
-
-AM_CONDITIONAL(BUILD_TESTS, test x$gtk_works = xyes)
+AM_PATH_GLIB(1.3.1,,
+ AC_MSG_ERROR([GLib 1.3.1 is required for building Pango]),
+ gmodule gobject)
AC_PATH_PROG(FRIBIDI_CONFIG, fribidi-config, no)
if test x$FRIBIDI_CONFIG = xno ; then
@@ -136,9 +133,52 @@ AM_CONDITIONAL(INCLUDE_THAI,echo $included_modules | grep '\(^\|,\)thai\($\|,\)'
#
AC_CHECK_FUNCS(flockfile)
+#
+# Check for Qt - which we use for building the viewer example, if
+# present
+#
+
+AC_ARG_WITH(qt, [ --with-qt=DIR Location where Qt is installed],,with_qt=yes)
+
+QTDIR=
+AC_MSG_CHECKING(For Qt location)
+
+if test "x$with_qt" = xyes ; then
+# Search for Qt in various possibly standard ocations
+ for dir in /usr/lib/qt-2.1.0 /usr/lib/qt-2.0.1 /usr/lib/qt-2.0.0 ; do
+ if test -x $dir/bin/moc ; then
+ QTDIR=$dir
+ break
+ fi
+ done
+
+else
+ if ! test "x$with_qt" = xno ; then
+ if test -x $with_qt/bin/moc ; then
+ QTDIR=$with_qt
+ fi
+ fi
+fi
+
+if test "x$QTDIR" = x ; then
+ AC_MSG_RESULT(none)
+else
+ AC_MSG_RESULT($QTDIR)
+
+ AC_PROG_CXX
+fi
+
+AM_CONDITIONAL(BUILD_QT_TEST, ! test "x$QTDIR" = x)
+AC_SUBST(QTDIR)
+
+#
+# Check for gtkdoc
+#
AC_CHECK_PROG(gtkdoc, gtkdoc-scan, yes, no)
AM_CONDITIONAL(HAVE_GTK_DOC, test x$gtkdoc = xyes)
+
+
AC_OUTPUT_COMMANDS([
cat > pango/module-defs.c <<EOTEXT
/* Autogenerated by configure. Do not edit */