summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2000-05-28 00:38:05 +0000
committerOwen Taylor <otaylor@src.gnome.org>2000-05-28 00:38:05 +0000
commit1a23b2c124df6830bc8a8027bd8b38ccc2c75531 (patch)
tree36998ab8a3d8d1211d5eec8069a8d84c98a96041 /configure.in
parent62244f7210302bf7608c6130185c17d3d2e714e0 (diff)
downloadpango-1a23b2c124df6830bc8a8027bd8b38ccc2c75531.tar.gz
Add libgobject.
Sat May 27 20:36:56 2000 Owen Taylor <otaylor@redhat.com> * pango/Makefile.am configure.in: Add libgobject. * pango/pango-fontmap.[ch]: GObject'ify PangoFontMap. (Pango now requires GLib-1.3 to compile) * pango/pangox-fontmap.c pango/pangox-private.h: Break the fontmap code in libpangox out into a separate file. Tue May 23 10:32:25 2000 Owen Taylor <otaylor@redhat.com> * pango/pango-layout.c (pango_layout_set_text): Allow -1 for the length.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index e915e250..57a7c934 100644
--- a/configure.in
+++ b/configure.in
@@ -45,16 +45,13 @@ AC_CHECK_LIB(fribidi, fribidi_map_range, :,
AC_MSG_ERROR([*** libfribidi not found.]), $FRIBIDI_LIBS)
-# We run glib-config separately to get the gmodule cflags so we
-# can add them to pango-config
-
AC_PATH_PROG(GLIB_CONFIG, glib-config, no)
if test x$GLIB_CONFIG = xno ; then
AC_MSG_ERROR([*** glib-config not found])
fi
-GLIB_CFLAGS="`$GLIB_CONFIG --cflags gmodule`"
+GLIB_CFLAGS="`$GLIB_CONFIG --cflags gmodule gobject`"
CFLAGS="$CFLAGS $GLIB_CFLAGS"
-GLIB_LIBS="`$GLIB_CONFIG --libs gmodule`"
+GLIB_LIBS="`$GLIB_CONFIG --libs gmodule gobject`"
AC_SUBST(GLIB_LIBS)
AC_SUBST(GLIB_CFLAGS)