summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2000-10-29 05:48:16 +0000
committerOwen Taylor <otaylor@src.gnome.org>2000-10-29 05:48:16 +0000
commit4cda3f186493ed8e6c3872a1deee080fd601e6df (patch)
tree2b5fb6479609639a2d258025987bb267448d4b75 /configure.in
parent50c23bd38e97cbe6dd1c5285aad3fa3ceeda8804 (diff)
downloadpango-4cda3f186493ed8e6c3872a1deee080fd601e6df.tar.gz
Fix up doc comments not to have obvious errors that gtk-doc barfs on.
Sun Oct 29 01:27:39 2000 Owen Taylor <otaylor@redhat.com> * pango/pangoft2-fontcache.c pango/pangoft2.[ch] pango/pangowin32.h: Fix up doc comments not to have obvious errors that gtk-doc barfs on. Correct parameter descriptions still need to be filled in. * configure.in pango/docs/Makefile.am: upgrade to have a real install rule, etc. * pango/docs/pango-sections.txt: Add various missing functions.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in40
1 files changed, 35 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 666b1012..d583e383 100644
--- a/configure.in
+++ b/configure.in
@@ -173,12 +173,42 @@ fi
AM_CONDITIONAL(BUILD_QT_TEST, test "x$QTDIR" != x)
AC_SUBST(QTDIR)
-#
-# Check for gtkdoc
-#
-AC_CHECK_PROG(gtkdoc, gtkdoc-scan, yes, no)
-AM_CONDITIONAL(HAVE_GTK_DOC, test x$gtkdoc = xyes)
+dnl **************************
+dnl *** Checks for gtk-doc ***
+dnl **************************
+
+AC_ARG_WITH(html-dir, [ --with-html-dir=PATH path to installed docs ])
+
+if test "x$with_html_dir" = "x" ; then
+ HTML_DIR='${datadir}/gtk-doc/html'
+else
+ HTML_DIR=$with_html_dir
+fi
+
+AC_SUBST(HTML_DIR)
+
+
+AC_CHECK_PROG(GTKDOC, gtkdoc-mkdb, true, false)
+AM_CONDITIONAL(HAVE_GTK_DOC, $GTKDOC)
+AC_SUBST(HAVE_GTK_DOC)
+
+AC_CHECK_PROG(DB2HTML, db2html, true, false)
+AM_CONDITIONAL(HAVE_DOCBOOK, $DB2HTML)
+
+dnl Let people disable the gtk-doc stuff.
+AC_ARG_ENABLE(gtk-doc, [ --enable-gtk-doc Use gtk-doc to build documentation [default=auto]], enable_gtk_doc="$enableval", enable_gtk_doc=auto)
+
+if test x$enable_gtk_doc = xauto ; then
+ if test x$GTKDOC = xtrue ; then
+ enable_gtk_doc=yes
+ else
+ enable_gtk_doc=no
+ fi
+fi
+dnl NOTE: We need to use a separate automake conditional for this
+dnl to make this work with the tarballs.
+AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes)
AC_OUTPUT_COMMANDS([