summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2000-05-08 15:50:13 +0000
committerOwen Taylor <otaylor@src.gnome.org>2000-05-08 15:50:13 +0000
commit5aea38b87e7237795178c9455d5e825e2f9507dd (patch)
tree897d7b1c9556c13eb98249b0a8e54ce9085f46bd /configure.in
parent1a9eb53c12b49c53aaaf56ef40220c28bd13df84 (diff)
downloadpango-5aea38b87e7237795178c9455d5e825e2f9507dd.tar.gz
Add a simple Thai shaper. (Reasonably complete but intended mostly for an
Mon May 8 16:19:22 2000 Owen Taylor <otaylor@redhat.com> * modules/thai/* modules/Makefile.am configure.in: Add a simple Thai shaper. (Reasonably complete but intended mostly for an example for the shape docs right now.) * pango/pangox.h (PANGO_X_GLYPH_INDEX): Protect arguments to macros.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 655bfaa2..e915e250 100644
--- a/configure.in
+++ b/configure.in
@@ -112,7 +112,7 @@ if ! test "x$with_included_modules" = xno || test "x$with_included_modules" = x
# If no modules specified, include all modules
if test "x$with_included_modules" = xyes ; then
- included_modules="arabic,devanagari,basic,hangul,tamil"
+ included_modules="arabic,devanagari,basic,hangul,tamil,thai"
else
included_modules="$with_included_modules"
fi
@@ -132,6 +132,7 @@ AM_CONDITIONAL(INCLUDE_BASIC,echo $included_modules | grep '\(^\|,\)basic\($\|,\
AM_CONDITIONAL(INCLUDE_DEVANAGARI,echo $included_modules | grep '\(^\|,\)devanagari\($\|,\)' > /dev/null)
AM_CONDITIONAL(INCLUDE_HANGUL,echo $included_modules | grep '\(^\|,\)hangul\($\|,\)' > /dev/null)
AM_CONDITIONAL(INCLUDE_TAMIL,echo $included_modules | grep '\(^\|,\)tamil\($\|,\)' > /dev/null)
+AM_CONDITIONAL(INCLUDE_THAI,echo $included_modules | grep '\(^\|,\)thai\($\|,\)' > /dev/null)
#
# We use flockfile to implement pango_getline() - should be moved to GLib
@@ -191,6 +192,7 @@ modules/basic/Makefile
modules/devanagari/Makefile
modules/hangul/Makefile
modules/tamil/Makefile
+modules/thai/Makefile
examples/Makefile
docs/Makefile
tools/Makefile