summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2001-05-02 15:39:00 +0000
committerOwen Taylor <otaylor@src.gnome.org>2001-05-02 15:39:00 +0000
commit8dddc32ed9aa784bfd6403a0992dce21f6c3b069 (patch)
treef926b8a808d79fe36a4c653fe887e17d119f0acb /configure.in
parent071af17799791f216db170770da8bef479fffa7c (diff)
downloadpango-8dddc32ed9aa784bfd6403a0992dce21f6c3b069.tar.gz
Add check to make sure #include FT_ERRORS_H works. (#54043)
Wed May 2 11:35:16 2001 Owen Taylor <otaylor@redhat.com> * configure.in (have_freetype): Add check to make sure #include FT_ERRORS_H works. (#54043) * configure.in: do not try to build modules using Xft if X is not available or was explicitely disabled.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e9c7523c..97abb3a6 100644
--- a/configure.in
+++ b/configure.in
@@ -76,6 +76,25 @@ if test "x$FREETYPE_CONFIG" != "xno" ; then
AC_CHECK_LIB(freetype, FT_New_Face, have_freetype=true
,:,$FREETYPE_LIBS)
+
+ if $have_freetype ; then
+ pango_save_cflags="$CFLAGS"
+ CFLAGS="$CFLAGS $FREETYPE_CFLAGS"
+
+ AC_MSG_CHECKING([For sufficiently new FreeType (at least 2.0.1)])
+ AC_TRY_COMPILE([
+#include <freetype/freetype.h>
+#include FT_ERRORS_H
+]
+ ,[(void)1;],:,have_freetype=false)
+ if $have_freetype ; then
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+ fi
+
+ CFLAGS="$pango_save_cflags"
+ fi
fi
AC_SUBST(FREETYPE_LIBS)
AC_SUBST(FREETYPE_CFLAGS)