summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSven Neumann <sven@gimp.org>2001-03-15 05:59:03 +0000
committerSven Neumann <neo@src.gnome.org>2001-03-15 05:59:03 +0000
commit4133033f2fc761441cc14b5aaf602a749db8fd1a (patch)
tree367c9d5e37747bc028548642a41f5f02d7ace8fe /configure.in
parent2ebe73ff42ea4cf55421d1a28f6cd1ef32aaa632 (diff)
downloadpango-4133033f2fc761441cc14b5aaf602a749db8fd1a.tar.gz
Makefile.am configure.in modules/*/Makefile.am make it compile without X
2001-03-15 Sven Neumann <sven@gimp.org> * Makefile.am * configure.in * modules/*/Makefile.am * pango/Makefile.am: make it compile without X headers
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 02d9d43a..e26c7506 100644
--- a/configure.in
+++ b/configure.in
@@ -41,11 +41,13 @@ fi
AC_SUBST(REBUILD)
if test x$no_x = xyes ; then
- AC_MSG_ERROR([X development libraries not found])
+ AC_MSG_WARN([X development libraries not found])
+ have_x=false
+else
+ X_LIBS="$X_LIBS -lX11"
+ have_x=true
fi
-
-X_LIBS="$X_LIBS -lX11"
-
+AM_CONDITIONAL(HAVE_X, $have_x)
#
# Find pkg-config