summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2002-02-14 20:32:19 +0000
committerOwen Taylor <otaylor@src.gnome.org>2002-02-14 20:32:19 +0000
commit43c16bed73a5a9335d554828675933318afd0c5f (patch)
tree4332a6d543392b1b1392048a810814cea2c6033d /configure.in
parent5da437ada2774bdf6ab0b104e42a396f574dcf08 (diff)
downloadpango-43c16bed73a5a9335d554828675933318afd0c5f.tar.gz
Respect QTDIR if set. Look for qt3 as well as qt2.
Thu Feb 14 14:46:26 2002 Owen Taylor <otaylor@redhat.com> * configure.in: Respect QTDIR if set. Look for qt3 as well as qt2.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 22 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index 1a747ff6..addab346 100644
--- a/configure.in
+++ b/configure.in
@@ -364,28 +364,35 @@ AC_CHECK_FUNCS(flockfile)
AC_ARG_WITH(qt, [ --with-qt=DIR Location where Qt is installed],,with_qt=yes)
-QTDIR=
if test "$CXX" != "" ; then
AC_MSG_CHECKING(For Qt location)
- if test "x$with_qt" = xyes ; then
+ if test "x$with_qt" = xyes ; then
# Search for Qt in a common location. The ls -r is an attempt to find the newest
- dirs=`cd /usr/lib && ls -d -r qt*`
- for dir in $dirs ; do
- case $dir in
- qt2*|qt-2*)
- if test -x /usr/lib/$dir/bin/moc ; then
- QTDIR=/usr/lib/$dir
- break
- fi
- ;;
- esac
- done
+ if test "x$QTDIR" != x ; then
+ if test -x $QTDIR/bin/moc ; then : ; else
+ QTDIR=
+ fi
+ else
+ dirs=`cd /usr/lib && ls -d -r qt*`
+ for dir in $dirs ; do
+ case $dir in
+ qt2*|qt-2*|qt3*|qt-3*)
+ if test -x /usr/lib/$dir/bin/moc ; then
+ QTDIR=/usr/lib/$dir
+ break
+ fi
+ ;;
+ esac
+ done
+ fi
else
if test "x$with_qt" != xno ; then
if test -x $with_qt/bin/moc ; then
QTDIR=$with_qt
fi
+ else
+ QTDIR=""
fi
fi
@@ -394,6 +401,8 @@ if test "$CXX" != "" ; then
else
AC_MSG_RESULT($QTDIR)
fi
+else
+ QTDIR=""
fi
if test x"$QTDIR" != "x" ; then