summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2001-10-26 16:54:06 +0000
committerOwen Taylor <otaylor@src.gnome.org>2001-10-26 16:54:06 +0000
commitf846ecca56933276c1a2262a2b5c55b62d2e4e07 (patch)
tree37093ce5d181e40ef67ba76a28660719ac9bf6ca /configure.in
parent76fef8a89da21166176fcde7a56429d1e88d60b3 (diff)
downloadpango-f846ecca56933276c1a2262a2b5c55b62d2e4e07.tar.gz
Version 0.21, require GLib-1.3.6PANGO_0_21
Thu Oct 25 11:06:54 2001 Owen Taylor <otaylor@redhat.com> * configure.in: Version 0.21, require GLib-1.3.6 * NEWS: Updates. Fri Oct 26 12:32:25 2001 Owen Taylor <otaylor@redhat.com> * configure.in: Don't use AC_CHECK_LIB to check for win32, since that causes problems with autoconf-2.13. * docs/Makefile.am: Fix to install images.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 96ecbcc9..3ec19b51 100644
--- a/configure.in
+++ b/configure.in
@@ -153,7 +153,12 @@ AM_CONDITIONAL(HAVE_XFT, $have_xft)
have_win32=false
WIN32_LIBS=""
WIN32_CFLAGS=""
-AC_CHECK_LIB(gdi32, GetTextMetricsA@8, have_win32=true, : )
+# The following doesn't work with autoconf-2.13, so we check $host instead
+# AC_CHECK_LIB(gdi32, GetTextMetricsA@8, have_win32=true, : )
+case "$host" in
+ *-*-mingw*|*-*-cygwin*) have_win32=true ;;
+esac
+
if test $have_win32 = true; then
WIN32_LIBS="-lgdi32"