summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2002-03-03 03:01:21 +0000
committerOwen Taylor <otaylor@src.gnome.org>2002-03-03 03:01:21 +0000
commit3e1fccd014c609f972bcfe002bb03b904d239e2d (patch)
tree9bb573f167798a80cd39e63d819af3ec87fa7d71 /configure.in
parentcd9e68bea720226c840cdf0babfd3f465f027aed (diff)
downloadpango-3e1fccd014c609f972bcfe002bb03b904d239e2d.tar.gz
Write examples/pango.modules in terms of .la files rather than direct
Sat Mar 2 21:57:55 2002 Owen Taylor <otaylor@redhat.com> * examples/Makefile.am (pango.modules): Write examples/pango.modules in terms of .la files rather than direct shared objects to avoid having to know soname extension. * pango/querymodules.c (main): Use G_MODULE_SUFFIX or .la to compare with filenames when querying modules, rather than hardcoded .so/.la. * configure.in (USE_LA_MODULES): On aix, load .la files since we can't guess the soname extension.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b18af8f3..c420c7df 100644
--- a/configure.in
+++ b/configure.in
@@ -480,6 +480,21 @@ dnl NOTE: We need to use a separate automake conditional for this
dnl to make this work with the tarballs.
AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes)
+dnl ********************************************************
+dnl * See whether we need to load our modules as .la files *
+dnl ********************************************************
+
+use_la_modules=false
+case $host in
+ *-aix*) use_la_modules=true
+esac
+
+if $use_la_modules ; then
+ AC_DEFINE(USE_LA_MODULES, 1, [Whether to load modules via .la files rather than directly])
+fi
+
+echo ================= $host ==================
+
dnl ******************************************************
dnl * See whether to include shared library dependencies *
dnl ******************************************************