summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2001-05-16 18:38:30 +0000
committerOwen Taylor <otaylor@src.gnome.org>2001-05-16 18:38:30 +0000
commite6858b1b195339b72f61f6818657bd6b24a2cfc6 (patch)
tree0d35c4f619bf0fc97aa1f948872d1eb179d23677 /configure.in
parent6aeaa59a980fa68e2bbbd28cbe026919642a7fa9 (diff)
downloadpango-e6858b1b195339b72f61f6818657bd6b24a2cfc6.tar.gz
Require libtool 1.4 when build out of CVS.
Tue May 1 16:03:48 2001 Owen Taylor <otaylor@redhat.com> * autogen.sh (libtool_version): Require libtool 1.4 when build out of CVS. * **/Makefile.am: Add inter-library dependencies, especially for the modules. Many cleanups to the module makefiles. * configure.in modules/indic/Makefile.am: Remove INCLUDE_ANY_INDIC conditional which doesn't seem to have any point and was definitely suspect as done. * modules/tamil/tamil-xft.c (MODULE_ENTRY): Fix prefix to be _pango_tamil instead of _pango_basic. * Makefile.am: Build modules/ after pango/ so we can make the modules depend on libpango/libpangox. * examples/Makefile.am: Remove spurious rule to rebuild makefile.mingw.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 2 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 3648276e..e3a68239 100644
--- a/configure.in
+++ b/configure.in
@@ -213,6 +213,7 @@ if test "x$with_included_modules" != xno || test "x$with_included_modules" = x ;
fi
AC_MSG_RESULT($included_modules)
+AM_CONDITIONAL(HAVE_INCLUDED_MODULES, test "x$included_modules" != x)
INCLUDED_X_MODULES=
INCLUDED_XFT_MODULES=
@@ -224,7 +225,7 @@ for module in $included_modules; do
else
dir=`echo $module | sed "s/-.*//"`
fi
-
+
if echo $module | grep -- "-xft\($\|,\)" > /dev/null; then
INCLUDED_XFT_MODULES="$INCLUDED_XFT_MODULES \$(top_builddir)/modules/$dir/libpango-$module.la"
elif echo $module | grep -- "-ft2\($\|,\)" > /dev/null; then
@@ -258,17 +259,6 @@ AM_CONDITIONAL(INCLUDE_BENGALI_X,echo $included_modules | grep '\(^\|,\)bengali-
AM_CONDITIONAL(INCLUDE_GUJARATI_X,echo $included_modules | grep '\(^\|,\)gujarati-x\($\|,\)' > /dev/null)
AM_CONDITIONAL(INCLUDE_DEVANAGARI_X,echo $included_modules | grep '\(^\|,\)devanagari-x\($\|,\)' > /dev/null)
-have_indic_modules="no"
-IFS="${IFS= }"; pango_save_ifs="$IFS"; IFS=","
-for module in $indic_modules; do
- if echo $included_modules | grep "\(^\| \)$module\(\$\| \)" > /dev/null; then
- have_indic_modules="yes"
- fi
-done
-IFS="$pango_save_ifs"
-
-AM_CONDITIONAL(INCLUDE_ANY_INDIC,test $have_indic_modules = yes)
-
#
# We use flockfile to implement pango_getline() - should be moved to GLib
#