summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2002-08-09 01:40:59 +0000
committerOwen Taylor <otaylor@src.gnome.org>2002-08-09 01:40:59 +0000
commit2308b3673a9bdc20fba610818597068bcb7e9067 (patch)
tree3c0f7fb6e7898bb047484646bb63b6e3abc51024 /configure.in
parent1592af4ef8ce10486b456c908c8ec79aee29ed27 (diff)
downloadpango-2308b3673a9bdc20fba610818597068bcb7e9067.tar.gz
Some fixes from #90267
Thu Aug 8 21:37:48 2002 Owen Taylor <otaylor@redhat.com> Some fixes from #90267 * configure.in: Fix case where freetype2 is not in default include path. Quiet some warnings if /usr/lib/qt* doesn't exist. * examples/Makefile.am: Fix problem where if no Qt was found, -I /include was in the CFLAGS.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index f759910e..a98d3ddd 100644
--- a/configure.in
+++ b/configure.in
@@ -156,8 +156,10 @@ if test "x$FREETYPE_CONFIG" != "xno" ; then
FREETYPE_CFLAGS=`$FREETYPE_CONFIG --cflags`
FREETYPE_LIBS=`$FREETYPE_CONFIG --libs`
- AC_CHECK_LIB(freetype, FT_New_Face, have_freetype=true
- ,:,$FREETYPE_LIBS)
+ pango_save_ldflags=$LDFLAGS
+ LDFLAGS="$LDFLAGS $FREETYPE_LIBS"
+ AC_CHECK_LIB(freetype, FT_New_Face, have_freetype=true, :)
+ LDFLAGS=$pango_save_ldflags
if $have_freetype ; then
pango_save_cppflags="$CPPFLAGS"
@@ -446,7 +448,7 @@ if test "$CXX" != "" ; then
QTDIR=
fi
else
- dirs=`cd /usr/lib && ls -d -r qt*`
+ dirs=`cd /usr/lib && ls -d -r qt* 2>/dev/null`
for dir in $dirs ; do
case $dir in
qt2*|qt-2*|qt3*|qt-3*)