summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2001-10-28 22:54:14 +0000
committerTor Lillqvist <tml@src.gnome.org>2001-10-28 22:54:14 +0000
commit53570e37a04c11518dc99c1b6357cff8182c1980 (patch)
tree6f8a9b437da29b7f2c951e812fba5fc9b4707b51 /configure.in
parentf5527477d469cf50063bad41de22138806748520 (diff)
downloadpango-53570e37a04c11518dc99c1b6357cff8182c1980.tar.gz
New file, used to build distribution package for Windows.
2001-10-29 Tor Lillqvist <tml@iki.fi> * pango-zip.sh.in: New file, used to build distribution package for Windows. * Makefile.am (EXTRA_DIST): Add pango-zip.sh. * configure.in: Check for lib.exe, set MS_LIB_AVAILABLE. Generate pango-zip.sh. * README.win32: Mention the ways to build Pango on Windows. * modules/Makefile.am * examples/Makefile.am: Se SOSUFFIX to so on Unix, dll on Windows. * pango/Makefile.am: Add rules to create MSVC import library if MS_LIB_AVAILABLE. Add rules to install and uninstall mingw and MSVC import libraries. * tests/Makefile.am: Link with libpangox.la only on Unix.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3ec19b51..2b0ac3a2 100644
--- a/configure.in
+++ b/configure.in
@@ -40,6 +40,11 @@ esac
AC_MSG_RESULT([$pango_os_win32])
AM_CONDITIONAL(OS_WIN32, test "$pango_os_win32" = "yes")
+if test "$pango_os_win32" = "yes"; then
+ AC_CHECK_PROG(ms_librarian, lib.exe, yes, no)
+fi
+AM_CONDITIONAL(MS_LIB_AVAILABLE, test x$ms_librarian = xyes)
+
changequote(,)dnl
if test "x$GCC" = "xyes"; then
case " $CFLAGS " in
@@ -579,6 +584,7 @@ pangox-uninstalled.pc
pangowin32-uninstalled.pc
pangoft2-uninstalled.pc
pangoxft-uninstalled.pc
+pango-zip.sh
],[case "$CONFIG_FILES" in
*pango-config*)chmod +x pango-config;;
esac])