summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2005-07-22 19:05:45 +0000
committerOwen Taylor <otaylor@src.gnome.org>2005-07-22 19:05:45 +0000
commit516a1c99afa7bb832e9edc69551b74d973ce75a3 (patch)
treec7b1cc8a8b4ec6d0cdb775856804a5a1607cce75 /configure.in
parenta998706c418584d6776e613925e8d7e633eebe8c (diff)
downloadpango-516a1c99afa7bb832e9edc69551b74d973ce75a3.tar.gz
Use -export-symbols-regex to control symbol exports, including not
2005-07-22 Owen Taylor <otaylor@redhat.com> * pango/Makefile.a configure.in: Use -export-symbols-regex to control symbol exports, including not exporting the symbols from opentype/. * modules/*/Makefile.am: Control symbol exports here as well, simplify using AC_SUBST() of MODULE_LIBTOOL_OPTIONS from configure.in. * pango/pangox-fontmap.c (engine_shape_covers): Cut-and-paste engine_shape_covers to avoid using a symbol from libpango. * pango/pango-utils.c: Make accidentally exported pango_aliases_ht static.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8601206f..ab8ae4e5 100644
--- a/configure.in
+++ b/configure.in
@@ -503,6 +503,26 @@ fi
AM_CONDITIONAL(ENABLE_MAN, test x$enable_man != xno)
dnl ********************************************************
+dnl * Options to pass to libtool
+dnl ********************************************************
+
+# Note that -module isn't included here since automake needs to see it to know
+# that something like pango-arabic-fc.la is a valid libtool archive
+#
+if test "$os_win32" != yes; then
+ # libtool option to control which symbols are exported
+ # right now, symbols starting with _ are not exported
+ LIBRARY_LIBTOOL_OPTIONS="-version-info $LT_VERSION_INFO "'-export-symbols-regex "^pango_.*"'
+ MODULE_LIBTOOL_OPTIONS="-export-dynamic -avoid-version "'-export-symbols-regex "^script_engine_.*"'
+else
+ # We currently use .def files on Windows (for gdk-pixbuf, gdk and gtk)
+ LIBRARY_LIBTOOL_OPTIONS="-version-info $LT_VERSION_INFO -no-undefined"
+ MODULE_LIBTOOL_OPTIONS="-export-dynamic -avoid-version -no-undefined"
+fi
+AC_SUBST(LIBRARY_LIBTOOL_OPTIONS)
+AC_SUBST(MODULE_LIBTOOL_OPTIONS)
+
+dnl ********************************************************
dnl * See whether we need to load our modules as .la files *
dnl ********************************************************