summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2006-06-06 18:26:31 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2006-06-06 18:26:31 +0000
commit54d3056aa100f9ef02e6d8239964b6cf8e0a5461 (patch)
treec423c0de06091266641bdaa4d9810b0bbb1795a4 /configure.in
parent477bb7dc64e98dcf3a0c713c0cd90905003dfb76 (diff)
downloadpango-54d3056aa100f9ef02e6d8239964b6cf8e0a5461.tar.gz
Bug 343966 – pango Cygwin build fixes Patch from Cygwin Ports
2006-06-06 Behdad Esfahbod <behdad@gnome.org> Bug 343966 – pango Cygwin build fixes Patch from Cygwin Ports maintainer. * configure.in: Use -no-undefined on all systems. [already on HEAD] * tests/Makefile.am: Add $(EXEEXT) where appropriate.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 9 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 9ed72b53..29049cd9 100644
--- a/configure.in
+++ b/configure.in
@@ -587,15 +587,16 @@ dnl ********************************************************
# Note that -module isn't included here since automake needs to see it to know
# that something like pango-arabic-fc.la is a valid libtool archive
#
-if test "$pango_os_win32" != yes; then
- # libtool option to control which symbols are exported
- # right now, symbols starting with _ are not exported
- LIBRARY_LIBTOOL_OPTIONS="-version-info $LT_VERSION_INFO "'-export-symbols-regex "^pango_.*"'
- MODULE_LIBTOOL_OPTIONS="-export-dynamic -avoid-version "'-export-symbols-regex "^script_engine_.*"'
-else
+LIBRARY_LIBTOOL_OPTIONS="-version-info $LT_VERSION_INFO -no-undefined"
+MODULE_LIBTOOL_OPTIONS="-export-dynamic -avoid-version -no-undefined"
+if test "$pango_os_win32" = yes; then
# We currently use .def files on Windows
- LIBRARY_LIBTOOL_OPTIONS="-version-info $LT_VERSION_INFO -no-undefined"
- MODULE_LIBTOOL_OPTIONS="-export-dynamic -avoid-version -no-undefined"
+ true
+else
+ # libtool option to control which symbols are exported
+ # right now, symbols starting with '_' are not exported
+ LIBRARY_LIBTOOL_OPTIONS="$LIBRARY_LIBTOOL_OPTIONS "'-export-symbols-regex "^pango_.*"'
+ MODULE_LIBTOOL_OPTIONS="$MODULE_LIBTOOL_OPTIONS "'-export-symbols-regex "^script_engine_.*"'
fi
AC_SUBST(LIBRARY_LIBTOOL_OPTIONS)
AC_SUBST(MODULE_LIBTOOL_OPTIONS)