summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorManish Singh <yosh@gimp.org>2005-02-04 02:25:02 +0000
committerManish Singh <yosh@src.gnome.org>2005-02-04 02:25:02 +0000
commit241888a1c9b54ddd973aabaa8009c7e5ff28704b (patch)
tree9ae7d02bb8d88e6ca3768c8e766ab0ea38c11084 /configure.in
parentc911edecf89a0ba523a77f45f0a97c73ed186a25 (diff)
downloadpango-241888a1c9b54ddd973aabaa8009c7e5ff28704b.tar.gz
use CAIRO_LIBS for all libcairo checks, and disable the cairo backend if
Thu Feb 3 18:23:27 2005 Manish Singh <yosh@gimp.org> * configure.in: use CAIRO_LIBS for all libcairo checks, and disable the cairo backend if we don't have Win32 nor FreeType support in cairo.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index b62ad658..4380202a 100644
--- a/configure.in
+++ b/configure.in
@@ -280,16 +280,17 @@ if $have_cairo ; then
pango_save_ldflags=$LDFLAGS
LDFLAGS="$LDFLAGS $CAIRO_LIBS"
AC_CHECK_LIB(cairo, cairo_win32_font_select_font, have_cairo_win32=true, :)
- LDFLAGS=$pango_save_ldflags
if $have_cairo_win32 && $have_win32; then
AC_DEFINE(HAVE_CAIRO_WIN32, 1, [Whether Cairo uses the Win32 GDI for fonts])
else
AC_CHECK_LIB(cairo, cairo_ft_font_lock_face, have_cairo_freetype=true, :)
- LDFLAGS=$pango_save_ldflags
if $have_cairo_freetype && $have_freetype ; then
AC_DEFINE(HAVE_CAIRO_FREETYPE, 1, [Whether Cairo uses FreeType for fonts])
+ else
+ have_cairo=false
fi
fi
+ LDFLAGS=$pango_save_ldflags
fi
AM_CONDITIONAL(HAVE_CAIRO, $have_cairo)