summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2006-04-29 23:09:12 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2006-04-29 23:09:12 +0000
commit29b48d2171562fb43b3c9ffc86e1904aff462d86 (patch)
tree5bd5fe3035cb7b77d39f9e6bddc3ca09989cc313 /configure.in
parentd52296311614adf06c07389e34fa2bd69dbc343a (diff)
downloadpango-29b48d2171562fb43b3c9ffc86e1904aff462d86.tar.gz
Require cairo >= 1.1.2. Also pass -no-undefined on all systems.
2006-04-29 Behdad Esfahbod <behdad@gnome.org> * configure.in: Require cairo >= 1.1.2. Also pass -no-undefined on * all systems. * pango/pangocairo-font.c (_pango_cairo_font_get_hex_box_info): Fix hexbox info to respect absolute sizes and no metrics hinting settings.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in50
1 files changed, 30 insertions, 20 deletions
diff --git a/configure.in b/configure.in
index 5658262a..bfd6f7b2 100644
--- a/configure.in
+++ b/configure.in
@@ -290,12 +290,14 @@ AC_CHECK_HEADER(Carbon/Carbon.h, [have_atsui=true], [have_atsui=true])
#
have_cairo=false
have_cairo_png=false
+have_cairo_ps=false
+have_cairo_pdf=false
have_cairo_xlib=false
have_cairo_freetype=false
have_cairo_win32=false
have_cairo_atsui=false
-PKG_CHECK_MODULES(CAIRO, cairo >= 1.0.0, have_cairo=true, :)
+PKG_CHECK_MODULES(CAIRO, cairo >= 1.1.2, have_cairo=true, :)
if $have_cairo ; then
pango_save_ldflags=$LDFLAGS
@@ -303,47 +305,54 @@ if $have_cairo ; then
INSTALLED_CAIRO_LIBS=`PKG_CONFIG_DISABLE_UNINSTALLED=yes $PKG_CONFIG --libs cairo`
LDFLAGS="$LDFLAGS $INSTALLED_CAIRO_LIBS"
- # A couple temporary checks, to not rely on cairo HEAD :(
- have_cairo_scaled_font_getters=false
- AC_CHECK_LIB(cairo, cairo_scaled_font_get_ctm, have_cairo_scaled_font_getters=true, :)
- if $have_cairo_scaled_font_getters; then
- AC_DEFINE(HAVE_CAIRO_SCALED_FONT_GETTERS, 1, [Whether Cairo has cairo_scaled_font_get_*()])
- fi
- have_cairo_scaled_font_text_extents=false
- AC_CHECK_LIB(cairo, cairo_scaled_font_text_extents, have_cairo_scaled_font_text_extents=true, :)
- if $have_cairo_scaled_font_text_extents; then
- AC_DEFINE(HAVE_CAIRO_SCALED_FONT_TEXT_EXTENTS, 1, [Whether Cairo has cairo_scaled_font_text_extents()])
- fi
AC_CHECK_LIB(cairo, cairo_surface_write_to_png, have_cairo_png=true, :)
if $have_cairo_png; then
AC_DEFINE(HAVE_CAIRO_PNG, 1, [Whether Cairo has PNG support])
fi
+
+ AC_CHECK_LIB(cairo, cairo_ps_surface_create, have_cairo_ps=true, :)
+ if $have_cairo_ps; then
+ AC_DEFINE(HAVE_CAIRO_PS, 1, [Whether Cairo has PS support])
+ fi
+
+ AC_CHECK_LIB(cairo, cairo_pdf_surface_create, have_cairo_pdf=true, :)
+ if $have_cairo_pdf; then
+ AC_DEFINE(HAVE_CAIRO_PDF, 1, [Whether Cairo has PDF support])
+ fi
+
AC_CHECK_LIB(cairo, cairo_xlib_surface_create, have_cairo_xlib=true, :)
if $have_cairo_xlib; then
AC_DEFINE(HAVE_CAIRO_XLIB, 1, [Whether Cairo has Xlib support])
fi
+
have_cairo=false
+
AC_CHECK_LIB(cairo, cairo_win32_scaled_font_select_font, have_cairo_win32=true, :)
if $have_cairo_win32 && $have_win32; then
AC_DEFINE(HAVE_CAIRO_WIN32, 1, [Whether Cairo uses the Win32 GDI for fonts])
have_cairo=true
fi
+
AC_CHECK_LIB(cairo, cairo_ft_scaled_font_lock_face, have_cairo_freetype=true, :)
if $have_cairo_freetype && $have_freetype ; then
AC_DEFINE(HAVE_CAIRO_FREETYPE, 1, [Whether Cairo uses FreeType for fonts])
have_cairo=true
fi
+
AC_CHECK_LIB(cairo, cairo_atsui_font_face_create_for_atsu_font_id, have_cairo_atsui=true, :)
if $have_cairo_atsui && $have_atsui ; then
AC_DEFINE(HAVE_CAIRO_ATSUI, 1, [Whether Cairo uses ATSUI for fonts])
have_cairo=true
fi
+
LDFLAGS=$pango_save_ldflags
fi
AM_CONDITIONAL(HAVE_CAIRO, $have_cairo)
AM_CONDITIONAL(HAVE_CAIRO_PNG, $have_cairo_png)
+AM_CONDITIONAL(HAVE_CAIRO_PS, $have_cairo_ps)
+AM_CONDITIONAL(HAVE_CAIRO_PDF, $have_cairo_pdf)
AM_CONDITIONAL(HAVE_CAIRO_XLIB, $have_cairo_xlib)
AM_CONDITIONAL(HAVE_CAIRO_WIN32, $have_cairo_win32 && $have_win32)
AM_CONDITIONAL(HAVE_CAIRO_FREETYPE, $have_cairo_freetype && $have_freetype)
@@ -586,15 +595,16 @@ dnl ********************************************************
# Note that -module isn't included here since automake needs to see it to know
# that something like pango-arabic-fc.la is a valid libtool archive
#
-if test "$pango_os_win32" != yes; then
- # libtool option to control which symbols are exported
- # right now, symbols starting with _ are not exported
- LIBRARY_LIBTOOL_OPTIONS="-version-info $LT_VERSION_INFO "'-export-symbols-regex "^pango_.*"'
- MODULE_LIBTOOL_OPTIONS="-export-dynamic -avoid-version "'-export-symbols-regex "^script_engine_.*"'
-else
+LIBRARY_LIBTOOL_OPTIONS="-version-info $LT_VERSION_INFO -no-undefined"
+MODULE_LIBTOOL_OPTIONS="-export-dynamic -avoid-version -no-undefined"
+if test "$pango_os_win32" = yes; then
# We currently use .def files on Windows
- LIBRARY_LIBTOOL_OPTIONS="-version-info $LT_VERSION_INFO -no-undefined"
- MODULE_LIBTOOL_OPTIONS="-export-dynamic -avoid-version -no-undefined"
+ true
+else
+ # libtool option to control which symbols are exported
+ # right now, symbols starting with '_' are not exported
+ LIBRARY_LIBTOOL_OPTIONS="$LIBRARY_LIBTOOL_OPTIONS "'-export-symbols-regex "^pango_.*"'
+ MODULE_LIBTOOL_OPTIONS="$MODULE_LIBTOOL_OPTIONS"'-export-symbols-regex "^script_engine_.*"'
fi
AC_SUBST(LIBRARY_LIBTOOL_OPTIONS)
AC_SUBST(MODULE_LIBTOOL_OPTIONS)