summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2006-01-30 23:57:25 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2006-01-30 23:57:25 +0000
commit71f0113fe55447c026fb00115c552a8762bf9e91 (patch)
tree174c103289d099fed851247b0c470cd81ea3ebe1 /configure.in
parenta117cdd81062b15b0b1021cfaf19a291b4faa773 (diff)
downloadpango-71f0113fe55447c026fb00115c552a8762bf9e91.tar.gz
Oops, removed all my changes the other time :(
2006-01-30 Behdad Esfahbod <behdad@gnome.org> Bug 328314 – Examples should use GOption instead of argcontext.c Patch from Antoine Dopffer. * examples/renderdemo.c: Use GOption for parsing cmd-line options. * examples/argcontext.c, examples/argcontext.h: Removed.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 17 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index c36d0403..8ae51a5e 100644
--- a/configure.in
+++ b/configure.in
@@ -280,6 +280,7 @@ AC_CHECK_HEADER(Carbon/Carbon.h, [have_atsui=true], [have_atsui=true])
# Checks for Cairo
#
have_cairo=false
+have_cairo_png=false
have_cairo_freetype=false
have_cairo_win32=false
have_cairo_atsui=false
@@ -291,26 +292,30 @@ if $have_cairo ; then
m4_pattern_allow([PKG_CONFIG_DISABLE_UNINSTALLED])
INSTALLED_CAIRO_LIBS=`PKG_CONFIG_DISABLE_UNINSTALLED=yes $PKG_CONFIG --libs cairo`
LDFLAGS="$LDFLAGS $INSTALLED_CAIRO_LIBS"
+
+ AC_CHECK_LIB(cairo, cairo_surface_write_to_png, have_cairo_png=true, :)
+
+ have_cairo=false
AC_CHECK_LIB(cairo, cairo_win32_scaled_font_select_font, have_cairo_win32=true, :)
if $have_cairo_win32 && $have_win32; then
AC_DEFINE(HAVE_CAIRO_WIN32, 1, [Whether Cairo uses the Win32 GDI for fonts])
- else
- AC_CHECK_LIB(cairo, cairo_ft_scaled_font_lock_face, have_cairo_freetype=true, :)
- if $have_cairo_freetype && $have_freetype ; then
- AC_DEFINE(HAVE_CAIRO_FREETYPE, 1, [Whether Cairo uses FreeType for fonts])
- else
- AC_CHECK_LIB(cairo, cairo_atsui_font_face_create_for_atsu_font_id, have_cairo_atsui=true, :)
- if $have_cairo_atsui && $have_atsui ; then
- AC_DEFINE(HAVE_CAIRO_ATSUI, 1, [Whether Cairo uses ATSUI for fonts])
- else
- have_cairo=false
- fi
- fi
+ have_cairo=true
+ fi
+ AC_CHECK_LIB(cairo, cairo_ft_scaled_font_lock_face, have_cairo_freetype=true, :)
+ if $have_cairo_freetype && $have_freetype ; then
+ AC_DEFINE(HAVE_CAIRO_FREETYPE, 1, [Whether Cairo uses FreeType for fonts])
+ have_cairo=true
+ fi
+ AC_CHECK_LIB(cairo, cairo_atsui_font_face_create_for_atsu_font_id, have_cairo_atsui=true, :)
+ if $have_cairo_atsui && $have_atsui ; then
+ AC_DEFINE(HAVE_CAIRO_ATSUI, 1, [Whether Cairo uses ATSUI for fonts])
+ have_cairo=true
fi
LDFLAGS=$pango_save_ldflags
fi
AM_CONDITIONAL(HAVE_CAIRO, $have_cairo)
+AM_CONDITIONAL(HAVE_CAIRO_PNG, $have_cairo_png)
AM_CONDITIONAL(HAVE_CAIRO_WIN32, $have_cairo_win32 && $have_win32)
AM_CONDITIONAL(HAVE_CAIRO_FREETYPE, $have_cairo_freetype && $have_freetype)
AM_CONDITIONAL(HAVE_CAIRO_ATSUI, $have_cairo_atsui && $have_atsui)