summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2006-11-27 22:03:30 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2006-11-27 22:03:30 +0000
commit93d18a9135830d74bec50f04ca1723cb68c4ff1d (patch)
treee3c90745ee362565eda1c2a9503038e3a9990d5d /configure.in
parent7d36abc19331579d1a9d0df8b2c41a9bf57dd669 (diff)
downloadpango-93d18a9135830d74bec50f04ca1723cb68c4ff1d.tar.gz
Bug 371388 – Add Thai langauage engine Patch from Theppitak
2006-11-27 Behdad Esfahbod <behdad@gnome.org> Bug 371388 – Add Thai langauage engine Patch from Theppitak Karoonboonyanan * configure.in: Look for libthai and enable thai-lang module. * modules/thai/Makefile.am: Hook thai-lang module. * modules/thai/thai-lang.c: New Thai language engine that uses libthai to do dictionary-based Thai line-breaking. * examples/test-thai.txt: Improved.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1919c1d5..8af8586b 100644
--- a/configure.in
+++ b/configure.in
@@ -390,6 +390,12 @@ if test "x$GLIB_VERSION_MAJOR_MINOR" = "x$GLIB_REQUIRED_VERSION_MAJOR_MINOR"; th
GLIB_CFLAGS="-DG_DISABLE_DEPRECATED $GLIB_CFLAGS"
fi
+#
+# Checks for LibThai
+#
+have_libthai=false
+LIBTHAI_REQUIRED_VERSION=0.1.3
+PKG_CHECK_MODULES(LIBTHAI, libthai >= $LIBTHAI_REQUIRED_VERSION, have_libthai=true, :)
#
# Modules to build
@@ -404,6 +410,10 @@ syriac_modules="syriac-fc"
thai_modules="thai-fc"
tibetan_modules="tibetan-fc"
+if $have_libthai ; then
+ thai_modules="$thai_modules,thai-lang"
+fi
+
all_modules="$arabic_modules,$basic_modules,$hangul_modules,$hebrew_modules,$indic_modules,$khmer_modules,$syriac_modules,$thai_modules,$tibetan_modules"
#
@@ -487,6 +497,7 @@ AM_CONDITIONAL(INCLUDE_INDIC_LANG, echo $included_modules | egrep '(^|,)indic-la
AM_CONDITIONAL(INCLUDE_KHMER_FC, echo $included_modules | egrep '(^|,)khmer-fc($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_SYRIAC_FC, echo $included_modules | egrep '(^|,)syriac-fc($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_THAI_FC, echo $included_modules | egrep '(^|,)thai-fc($|,)' > /dev/null)
+AM_CONDITIONAL(INCLUDE_THAI_LANG, echo $included_modules | egrep '(^|,)thai-lang($|,)' > /dev/null)
AM_CONDITIONAL(INCLUDE_TIBETAN_FC, echo $included_modules | egrep '(^|,)tibetan-fc($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_ARABIC_FC, echo $dynamic_modules | egrep '(^|,)arabic-fc($|,)' > /dev/null)
@@ -502,6 +513,7 @@ AM_CONDITIONAL(DYNAMIC_INDIC_LANG, echo $dynamic_modules | egrep '(^|,)indic-lan
AM_CONDITIONAL(DYNAMIC_KHMER_FC, echo $dynamic_modules | egrep '(^|,)khmer-fc($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_SYRIAC_FC, echo $dynamic_modules | egrep '(^|,)syriac-fc($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_THAI_FC, echo $dynamic_modules | egrep '(^|,)thai-fc($|,)' > /dev/null)
+AM_CONDITIONAL(DYNAMIC_THAI_LANG, echo $dynamic_modules | egrep '(^|,)thai-lang($|,)' > /dev/null)
AM_CONDITIONAL(DYNAMIC_TIBETAN_FC, echo $dynamic_modules | egrep '(^|,)tibetan-fc($|,)' > /dev/null)
#