summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2006-06-21 07:11:34 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2006-06-21 07:11:34 +0000
commitea7d6e0e2a206054632c881450732fae697b8596 (patch)
tree1861f080d5f846d98c9f66d59cb74e5d080c8d8b /configure.in
parent40e01dd122f07733b1419226291d0d11acf5098c (diff)
downloadpango-ea7d6e0e2a206054632c881450732fae697b8596.tar.gz
Just call gnome-autogen.sh. The old autogen.sh had poor version checking
2006-06-21 Behdad Esfahbod <behdad@gnome.org> * autogen.sh: Just call gnome-autogen.sh. The old autogen.sh had poor version checking and was borking with libtool 2.x. * Makefile.am: * configure.in: * pango-zip.sh.in: * pango/Makefile.am: * pango/pango.rc.in: * pango/pangoft2.rc.in: * pango/pangowin32.rc.in: Rename LT_* variables such that autoconf doesn't err on "possibly undefined macros".
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index f371db5f..9576a614 100644
--- a/configure.in
+++ b/configure.in
@@ -75,11 +75,10 @@ dnl libtool versioning
m4_define([lt_current], [m4_eval(100 * pango_minor_version + pango_micro_version - pango_interface_age)])
m4_define([lt_revision], [pango_interface_age])
m4_define([lt_age], [m4_eval(pango_binary_age - pango_interface_age)])
-LT_VERSION_INFO="lt_current():lt_revision():lt_age()"
-LT_CURRENT_MINUS_AGE=m4_eval(lt_current - lt_age)
+VERSION_INFO="lt_current():lt_revision():lt_age()"
+PANGO_CURRENT_MINUS_AGE=m4_eval(lt_current - lt_age)
-AC_SUBST(LT_VERSION_INFO)
-AC_SUBST(LT_CURRENT_MINUS_AGE)
+AC_SUBST(PANGO_CURRENT_MINUS_AGE)
dnl ==========================================================================
@@ -595,7 +594,7 @@ dnl ********************************************************
# Note that -module isn't included here since automake needs to see it to know
# that something like pango-arabic-fc.la is a valid libtool archive
#
-LIBRARY_LIBTOOL_OPTIONS="-version-info $LT_VERSION_INFO -no-undefined"
+LIBRARY_LIBTOOL_OPTIONS="-version-info $VERSION_INFO -no-undefined"
MODULE_LIBTOOL_OPTIONS="-export-dynamic -avoid-version -no-undefined"
if test "$pango_os_win32" = yes; then
# We currently use .def files on Windows