summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2001-01-03 10:45:12 +0000
committerAlexander Larsson <alexl@src.gnome.org>2001-01-03 10:45:12 +0000
commitd5b358fe3e5123842533ea445460d8a337eced5d (patch)
treec51bb9232a7933ca280f68737a0c60b4c9b11250 /configure.in
parentdc23b8bf572adc64cb57be39fdaf02732e50bb72 (diff)
downloadpango-d5b358fe3e5123842533ea445460d8a337eced5d.tar.gz
Update the default list of included modules for
2001-01-03 Alexander Larsson <alexl@redhat.com> * configure.in: Update the default list of included modules for --with-included-modules=yes to include all new modules. Split INCLUDED_MODULES and module-defs.c into per shaper engine type lists. * modules/arabic/Makefile.am: Build libpango-arabic-xft.la if INCLUDE_ARABIC_XFT. * modules/arabic/arabic-xft.c: Change module prefix to _pango_arabic_xft_ * modules/basic/Makefile.am: Build static libs for all included modules. * modules/basic/basic-ft2.c: Change module prefix to _pango_basic_ft2_ * modules/basic/basic-xft.c: Change module prefix to _pango_basic_xft_ * pango/Makefile.am: Include correct module-defs-XXX in libs. * pango/modules.h: Split _pango_included_modules[] into separate lists. * pango/pangox.c: * pango/pangoft2.c: * pango/pangoxft-fontmap.c: Register built in modules.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in116
1 files changed, 99 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index c0b76ce6..7c977d0a 100644
--- a/configure.in
+++ b/configure.in
@@ -146,13 +146,14 @@ AC_MSG_CHECKING(modules to link statically)
AC_ARG_WITH(included_modules, [ --with-included-modules=MODULE1,MODULE2,... Build the given modules into Pango])
indic_modules="gurmukhi,bengali,gujarati,devanagari,myanmar"
+all_modules="arabic,arabic-xft,basic,basic-ft2,basic-xft,hangul,tamil,thai,$indic_modules"
included_modules=""
if test "x$with_included_modules" != xno || test "x$with_included_modules" = x ; then
# If no modules specified, include all modules
if test "x$with_included_modules" = xyes ; then
- included_modules="arabic,basic,hangul,tamil,thai,$indic_modules"
+ included_modules="$all_modules"
else
included_modules="$with_included_modules"
fi
@@ -160,21 +161,40 @@ fi
AC_MSG_RESULT($included_modules)
-INCLUDED_MODULES=
+INCLUDED_X_MODULES=
+INCLUDED_XFT_MODULES=
+INCLUDED_FT2_MODULES=
IFS="${IFS= }"; pango_save_ifs="$IFS"; IFS=","
for module in $included_modules; do
- if echo $indic_modules | grep "\(^\| \)$module\(\$\| \)" > /dev/null; then
- INCLUDED_MODULES="$INCLUDED_MODULES \$(top_builddir)/modules/indic/libpango-$module.la"
+ if ! (echo "$all_modules" | grep "\(^\|,\)$module\(\$\|,\)" > /dev/null); then
+ AC_MSG_ERROR([the specified module $module does not exist])
else
- INCLUDED_MODULES="$INCLUDED_MODULES \$(top_builddir)/modules/$module/libpango-$module.la"
+ if echo $indic_modules | grep "\(^\| \)$module\(\$\| \)" > /dev/null; then
+ dir=indic
+ else
+ dir=`echo $module | sed "s/-.*//"`
+ fi
+
+ if echo $module | grep -- "-xft" > /dev/null; then
+ INCLUDED_XFT_MODULES="$INCLUDED_XFT_MODULES \$(top_builddir)/modules/$dir/libpango-$module.la"
+ elif echo $module | grep -- "-ft2" > /dev/null; then
+ INCLUDED_FT2_MODULES="$INCLUDED_FT2_MODULES \$(top_builddir)/modules/$dir/libpango-$module.la"
+ else
+ INCLUDED_X_MODULES="$INCLUDED_X_MODULES \$(top_builddir)/modules/$dir/libpango-$module.la"
+ fi
fi
done
IFS="$pango_save_ifs"
-AC_SUBST(INCLUDED_MODULES)
+AC_SUBST(INCLUDED_X_MODULES)
+AC_SUBST(INCLUDED_XFT_MODULES)
+AC_SUBST(INCLUDED_FT2_MODULES)
AM_CONDITIONAL(INCLUDE_ARABIC,echo $included_modules | grep '\(^\|,\)arabic\($\|,\)' > /dev/null)
+AM_CONDITIONAL(INCLUDE_ARABIC_XFT,echo $included_modules | grep '\(^\|,\)arabic-xft\($\|,\)' > /dev/null)
AM_CONDITIONAL(INCLUDE_BASIC,echo $included_modules | grep '\(^\|,\)basic\($\|,\)' > /dev/null)
+AM_CONDITIONAL(INCLUDE_BASIC_FT2,echo $included_modules | grep '\(^\|,\)basic-ft2\($\|,\)' > /dev/null)
+AM_CONDITIONAL(INCLUDE_BASIC_XFT,echo $included_modules | grep '\(^\|,\)basic-xft\($\|,\)' > /dev/null)
AM_CONDITIONAL(INCLUDE_HANGUL,echo $included_modules | grep '\(^\|,\)hangul\($\|,\)' > /dev/null)
AM_CONDITIONAL(INCLUDE_TAMIL,echo $included_modules | grep '\(^\|,\)tamil\($\|,\)' > /dev/null)
AM_CONDITIONAL(INCLUDE_THAI,echo $included_modules | grep '\(^\|,\)thai\($\|,\)' > /dev/null)
@@ -212,7 +232,7 @@ QTDIR=
AC_MSG_CHECKING(For Qt location)
if test "x$with_qt" = xyes ; then
-# Search for Qt in various possibly standard ocations
+# Search for Qt in various possibly standard locations
for dir in /usr/lib/qt-2.2.0 /usr/lib/qt-2.1.0 /usr/lib/qt-2.0.1 /usr/lib/qt-2.0.0 /usr/lib/qt2 ; do
if test -x $dir/bin/moc ; then
QTDIR=$dir
@@ -278,7 +298,7 @@ AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes)
AC_OUTPUT_COMMANDS([
-cat > pango/module-defs.c <<EOTEXT
+cat > pango/module-defs.h <<EOTEXT
/* Autogenerated by configure. Do not edit */
#include "modules.h"
@@ -287,31 +307,93 @@ EOTEXT
IFS="${IFS= }"; pango_save_ifs="$IFS"; IFS=","
for module in $included_modules; do
- cat >> pango/module-defs.c <<EOTEXT
-extern void _pango_${module}_script_engine_list (PangoEngineInfo **engines, int *n_engines);
-extern PangoEngine *_pango_${module}_script_engine_load (const char *id);
-extern void _pango_${module}_script_engine_unload (PangoEngine *engine);
+ module_c=`echo $module | sed s/-/_/`
+ cat >> pango/module-defs.h <<EOTEXT
+extern void _pango_${module_c}_script_engine_list (PangoEngineInfo **engines, int *n_engines);
+extern PangoEngine *_pango_${module_c}_script_engine_load (const char *id);
+extern void _pango_${module_c}_script_engine_unload (PangoEngine *engine);
EOTEXT
done
IFS="$pango_save_ifs"
-cat >> pango/module-defs.c <<EOTEXT
+### X modules
+cat > pango/module-defs-x.c <<EOTEXT
+/* Autogenerated by configure. Do not edit */
+
+#include "module-defs.h"
+
+PangoIncludedModule _pango_included_x_modules[] = {
+EOTEXT
+
+IFS="${IFS= }"; pango_save_ifs="$IFS"; IFS=","
+for module in $included_modules; do
+ if ! (echo $module | grep -- "-ft2" > /dev/null || echo $module | grep -- "-xft" > /dev/null); then
+ module_c=`echo $module | sed s/-/_/`
+ cat >> pango/module-defs-x.c <<EOTEXT
+ { _pango_${module_c}_script_engine_list, _pango_${module_c}_script_engine_load,_pango_${module_c}_script_engine_unload },
+EOTEXT
+ fi
+done
+
+IFS="$pango_save_ifs"
+
+cat >> pango/module-defs-x.c <<EOTEXT
+ { NULL, NULL, NULL },
+};
+EOTEXT
+
+
+### XFT modules
+cat > pango/module-defs-xft.c <<EOTEXT
+/* Autogenerated by configure. Do not edit */
+
+#include "module-defs.h"
-PangoIncludedModule _pango_included_modules[] = {
+PangoIncludedModule _pango_included_xft_modules[] = {
EOTEXT
IFS="${IFS= }"; pango_save_ifs="$IFS"; IFS=","
for module in $included_modules; do
- cat >> pango/module-defs.c <<EOTEXT
- { _pango_${module}_script_engine_list, _pango_${module}_script_engine_load,_pango_${module}_script_engine_unload },
+ if echo $module | grep -- "-xft" > /dev/null; then
+ module_c=`echo $module | sed s/-/_/`
+ cat >> pango/module-defs-xft.c <<EOTEXT
+ { _pango_${module_c}_script_engine_list, _pango_${module_c}_script_engine_load,_pango_${module_c}_script_engine_unload },
EOTEXT
+ fi
+done
+
+IFS="$pango_save_ifs"
+
+cat >> pango/module-defs-xft.c <<EOTEXT
+ { NULL, NULL, NULL },
+};
+EOTEXT
+
+
+### FT2 modules
+cat > pango/module-defs-ft2.c <<EOTEXT
+/* Autogenerated by configure. Do not edit */
+
+#include "module-defs.h"
+
+PangoIncludedModule _pango_included_ft2_modules[] = {
+EOTEXT
+
+IFS="${IFS= }"; pango_save_ifs="$IFS"; IFS=","
+for module in $included_modules; do
+ if echo $module | grep -- "-ft2" > /dev/null; then
+ module_c=`echo $module | sed s/-/_/`
+ cat >> pango/module-defs-ft2.c <<EOTEXT
+ { _pango_${module_c}_script_engine_list, _pango_${module_c}_script_engine_load,_pango_${module_c}_script_engine_unload },
+EOTEXT
+ fi
done
IFS="$pango_save_ifs"
-cat >> pango/module-defs.c <<EOTEXT
+cat >> pango/module-defs-ft2.c <<EOTEXT
{ NULL, NULL, NULL },
};
EOTEXT