summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2000-07-19 16:36:30 +0000
committerTor Lillqvist <tml@src.gnome.org>2000-07-19 16:36:30 +0000
commitdb5e31a4949f00231978cdd721d5014c585cccf4 (patch)
treec3dae830edc7179b46b9b256dd102ec21b065555 /configure.in
parentc85f6672f3329705ed186d8eb50f71528e1d087d (diff)
downloadpango-db5e31a4949f00231978cdd721d5014c585cccf4.tar.gz
Don't try to use the ! command, not available in all systems. Move the !
2000-07-19 Tor Lillqvist <tml@iki.fi> * configure.in: Don't try to use the ! command, not available in all systems. Move the ! inside the test instead. * pango-config.in: Change order of --cflags output, so that we can build with both GLib 1.2 and 1.3 installed. * modules/devanagari/dev-ligatures.h: No C++ comments, thanks. * pango/break.c: Fix gccism, non-constant initailiser. * pango/pango-fontmap.c: Don't return value from void functions. * pango/pango-utils.c: Must have at least empty statement after a label.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index c32cca2a..a9af7389 100644
--- a/configure.in
+++ b/configure.in
@@ -60,7 +60,7 @@ AC_ARG_WITH(libiconv, [ --with-libiconv Use the libiconv library ],,with_lib
found_iconv=no
-if ! test "x$with_libiconv" = "xyes" ; then
+if test "x$with_libiconv" != "xyes" ; then
#
# Check in the C library
#
@@ -92,7 +92,7 @@ AC_SUBST(UNICODE_LIBS)
AC_ARG_WITH(included_modules, [ --with-included-modules=MODULE1,MODULE2,... Build the given modules into Pango])
included_modules=""
-if ! test "x$with_included_modules" = xno || test "x$with_included_modules" = x ; then
+if test "x$with_included_modules" != xno || test "x$with_included_modules" = x ; then
# If no modules specified, include all modules
if test "x$with_included_modules" = xyes ; then
@@ -143,7 +143,7 @@ if test "x$with_qt" = xyes ; then
done
else
- if ! test "x$with_qt" = xno ; then
+ if test "x$with_qt" != xno ; then
if test -x $with_qt/bin/moc ; then
QTDIR=$with_qt
fi